Uploaded image for project: 'Teiid'
  1. Teiid
  2. TEIID-1388

Appears to be a limit of only one functional SalesForce connector in Teiid at a time.

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Done
    • Affects Version/s: 7.1.1
    • Fix Version/s: 7.1.1
    • Component/s: Salesforce Connector
    • Labels:
      None
    • Environment:

      Teiid 7.1.1 in EDS ER5, JBDS Beta2, RHEL 5.1

    • Affects:
      Documentation (Ref Guide, User Guide, etc.)

      Description

      It appears they only one SalesForce connector can be run at a time. If you preview a model from Designer and there are no SF connections in Teiid, it works. When you create a DS for the VDB and deploy, the VDB cannot get connections from SalesForce. If you delete the preview VDB and Datasource, then the deployed VDB begins working.

      I originally suspected that the problem might be that we are running out of connections; SalesForce limits you to 5 simultaneous connections per username/password. But I deployed the two DataSources with different credentials, and the result did not change. Need to investigate more.

      Think that we do need to default the SF DS to a pool of 1 and then doc that it should be bumped to 5 for production. The current default is 10, and that should never be. Even 5 will exhaust the limit with just a preview connection.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  rareddy Ramesh Reddy
                  Reporter:
                  jdoyle John Doyle
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: