Uploaded image for project: 'WildFly'
  1. WildFly
  2. WFLY-10372

Upgrade to Hibernate Validator 6.0.10.Final

    Details

      Description

      This version fixes a couple of important issues:

      • https://hibernate.atlassian.net/browse/HV-1604 - Initializing JPATraversableResolver fails with IllegalAccessException: this is a regression from 6.0.3.Final, the JPATraversableResolver was not correctly instantiated and thus not used, even in a JPA environment.
      • https://hibernate.atlassian.net/browse/HV-1609 - CDI extension should not rely on @WithAnnotations filtering: @WithAnnotations does not consider the annotations in the class hierarchy so a bean with constraint annotations only in the class hierarchy would not see these constraints applied.
      • https://hibernate.atlassian.net/browse/HV-1614 - Unable to specify constraints at more than 1 nested parameter of a typed container: in the programmatic API, nested container element constraints and cascading were not working as expected.

      It is only available in EE8 preview mode.

      Note: this upgrade will require we upgrade the Bean Validation TCK used to validate EE8 to 2.0.3.Final (some tests will fail otherwise).

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  guillaume.smet Guillaume Smet
                  Reporter:
                  guillaume.smet Guillaume Smet
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: