Uploaded image for project: 'Weld'
  1. Weld
  2. WELD-2543

Upgrade wildfly-arquillian from 2.1.0.Final to 2.1.1.Final

    Details

    • Steps to Reproduce:
      Hide

      git clone git@github.com:wildfly/wildfly.git
      cd wildfly && mvn clean install -DskipTests -Denforcer.skip=true -Dcheckstyle.skip=true
      export JBOSS_HOME="`find dist/target/ -maxdepth 1 -name "wildfly*" -type d | xargs -I {} readlink -m {}`"
      

      Then run the TCK against WildFly.

      Show
      git clone git@github.com:wildfly/wildfly.git cd wildfly && mvn clean install -DskipTests -Denforcer.skip=true -Dcheckstyle.skip=true export JBOSS_HOME="`find dist/target/ -maxdepth 1 -name "wildfly*" -type d | xargs -I {} readlink -m {}`" Then run the TCK against WildFly.

      Description

      There is a bug fixed in WFARQ-35 which relied on a WildFly bug that allowed some runtime only attributes to be exposed. The bug was fixed in the current upstream of WildFly resulting in test and Weld TCK failures when executing on the latest version of WildFly. This can simply be fixed by upgrading wildfly-arquillian to 2.1.1.Final.

      Diff: https://github.com/wildfly/wildfly-arquillian/compare/2.1.0.Final...2.1.1.Final

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                jamezp James Perkins
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: