Uploaded image for project: 'Teiid Designer'
  1. Teiid Designer
  2. TEIIDDES-3055

non-integer VDB version missing validation warning

    Details

      Description

      The VDB validation logic is missing the logic to catch a number format exception when validating the VDB version string. Need to wrap the logic in a try/catch block in VdbUtil.validateVdbModelsInWorkspace()

      Here's an example of a message: The PartsSupplier VDB's version number 1.0.1 is not an integer and will not deploy to a Teiid runtime version less than 9.0. Your current default Teiid server version is: 8.12.5

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                blafond Barry LaFond
                Reporter:
                blafond Barry LaFond
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: