Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Trivial
    • Resolution: Done
    • Affects Version/s: 9.1
    • Fix Version/s: 9.2
    • Component/s: Query Engine
    • Labels:
      None

      Description

      TEIID30003 text:

      Without required support property {0}, pushdown will not be enabled for {1} on translator {2}.

      However, in code, it's called:

      private static void setSupports(Object connectorID, BasicSourceCapabilities tgtCaps, Capability cap, boolean supports, Capability... required) {
          ...
          for (Capability capability : required) {
              ...
              LogManager.logWarning(LogConstants.CTX_CONNECTOR, QueryPlugin.Util.gs(QueryPlugin.Event.TEIID30003, cap, capability, connectorID));
              ...
          }
          ...
      }
      

      I.e. required capability is second ('1') attribute, not first ('0').

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                jdurani Juraj Duráni
                Reporter:
                jdurani Juraj Duráni
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: