Details

    • Type: Component  Upgrade Component Upgrade
    • Status: Closed Closed (View Workflow)
    • Priority: Major Major
    • Resolution: Won't Fix Won't Fix
    • Affects Version/s: 1.0.0-beta-7
    • Fix Version/s: None
    • Component/s: impl-maven
    • Labels:
      None
    • Bugzilla Update:
      Perform
    • Similar Issues:
      Show 10 results 

      Description

      Aether should be updated to the latest version, as it was done in upstream.

      This will make packaging of ShrinkWrap Maven resolver in Fedora much easier.

      Due to Aether Maven repository changes, a fix for Maven Repository types is required (
      https://gist.github.com/1362504):

      aused by: java.lang.reflect.InvocationTargetException
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      	at org.jboss.arquillian.container.test.impl.client.deployment.AnnotationDeploymentScenarioGenerator.invoke(AnnotationDeploymentScenarioGenerator.java:156)
      	... 48 more
      Caused by: java.lang.RuntimeException: Could not create new descriptor instance
      	at org.jboss.shrinkwrap.resolver.api.DependencyBuilderInstantiator.createFromUserView(DependencyBuilderInstantiator.java:101)
      	at org.jboss.shrinkwrap.resolver.api.DependencyResolvers.use(DependencyResolvers.java:39)
      	at org.scalabox.lift.helloworld.HelloWorldTest$.deployment(HelloWorldTest.scala:93)
      	at org.scalabox.lift.helloworld.HelloWorldTest.deployment(HelloWorldTest.scala)
      	... 53 more
      Caused by: java.lang.reflect.InvocationTargetException
      	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
      	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
      	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
      	at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
      	at org.jboss.shrinkwrap.resolver.api.DependencyBuilderInstantiator.createFromUserView(DependencyBuilderInstantiator.java:96)
      	... 56 more
      Caused by: java.lang.IllegalArgumentException: No manager available for local repository /Users/g/.m2/repository of type enhanced using the available factories EnhancedLocalRepositoryManagerFactory, SimpleLocalRepositoryManagerFactory
      	at org.sonatype.aether.impl.internal.DefaultRepositorySystem.newLocalRepositoryManager(DefaultRepositorySystem.java:454)
      	at org.jboss.shrinkwrap.resolver.impl.maven.MavenManagerBuilder.localRepositoryManager(MavenManagerBuilder.java:106)
      	at org.jboss.shrinkwrap.resolver.impl.maven.MavenRepositorySystem.getSession(MavenRepositorySystem.java:79)
      	at org.jboss.shrinkwrap.resolver.impl.maven.MavenBuilderImpl.<init>(MavenBuilderImpl.java:110)
      	... 61 more
      Caused by: org.sonatype.aether.repository.NoLocalRepositoryManagerException: No manager available for local repository /Users/g/.m2/repository of type enhanced using the available factories EnhancedLocalRepositoryManagerFactory, SimpleLocalRepositoryManagerFactory
      	at org.sonatype.aether.impl.internal.DefaultLocalRepositoryProvider.newLocalRepositoryManager(DefaultLocalRepositoryProvider.java:139)
      	at org.sonatype.aether.impl.internal.DefaultRepositorySystem.newLocalRepositoryManager(DefaultRepositorySystem.java:450)
      

        Activity

        RH Bugzilla Integration
        added a comment -

        Fedora Update System <updates@fedoraproject.org> changed the Status of bug 829745 from MODIFIED to ON_QA

        Show
        RH Bugzilla Integration
        added a comment - Fedora Update System <updates@fedoraproject.org> changed the Status of bug 829745 from MODIFIED to ON_QA
        RH Bugzilla Integration
        added a comment -

        Fedora Update System <updates@fedoraproject.org> changed the Status of bug 829745 from ON_QA to CLOSED

        Show
        RH Bugzilla Integration
        added a comment - Fedora Update System <updates@fedoraproject.org> changed the Status of bug 829745 from ON_QA to CLOSED
        RH Bugzilla Integration
        added a comment -

        Fedora Update System <updates@fedoraproject.org> made a comment on bug 829745

        shrinkwrap-resolver-1.0.0-0.1.beta7.fc17 has been pushed to the Fedora 17 stable repository.

        Show
        RH Bugzilla Integration
        added a comment - Fedora Update System <updates@fedoraproject.org> made a comment on bug 829745 shrinkwrap-resolver-1.0.0-0.1.beta7.fc17 has been pushed to the Fedora 17 stable repository.
        Karel Piwko
        added a comment -

        ShrinkWrap Resolvers 1.0.0-beta-7 was replaced by ShrinkWrap Resolvers in Fedora.

        As there is no need no maintain any version from 1.X stream, marking as won't fix.

        Show
        Karel Piwko
        added a comment - ShrinkWrap Resolvers 1.0.0-beta-7 was replaced by ShrinkWrap Resolvers in Fedora. As there is no need no maintain any version from 1.X stream, marking as won't fix.
        RH Bugzilla Integration
        added a comment -

        Karel Piwko <kpiwko@redhat.com> made a comment on bug 829745

        • by ShrinkWrap Resolvers 2.0.0
        Show
        RH Bugzilla Integration
        added a comment - Karel Piwko <kpiwko@redhat.com> made a comment on bug 829745 by ShrinkWrap Resolvers 2.0.0

          People

          • Assignee:
            Karel Piwko
            Reporter:
            Karel Piwko
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: