Uploaded image for project: 'ShrinkWrap Resolvers'
  1. ShrinkWrap Resolvers
  2. SHRINKRES-284

It shouldn't contain a CDI API dependency in the set of transitive dependencies

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 3.0.0
    • Fix Version/s: 3.0.1
    • Component/s: maven
    • Labels:
      None

      Description

      SWR shouldn't contain a CDI API dependency in the set of transitive dependencies otherwise it can fail with:

      SEVERE: Exception while loading the app : CDI deployment failure:WELD-000144: CDI API version mismatch. CDI 1.0 API detected on classpath. Weld requires version 1.1 or better. '

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                mjobanek Matous Jobanek
                Reporter:
                mjobanek Matous Jobanek
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: