Tools (JBoss Tools)
  1. Tools (JBoss Tools)
  2. JBIDE-7254

[BPEL] Prevented recursive attempt to activate part ProjectExplorer while activating bpeleditor

    Details

    • Type: Bug Bug
    • Status: Closed Closed (View Workflow)
    • Priority: Major Major
    • Resolution: Done
    • Affects Version/s: 3.2.0.Beta1
    • Fix Version/s: 3.2.0.Beta2
    • Component/s: bpel
    • Labels:
      None
    • Environment:
      Linux x64
    • Steps to Reproduce:

      Create new BPEL project
      Create new BPEL process
      Close editor that opened.
      Open .bpel file by doubleclicking
      You get warning with stacktrace in error log

      Show
      Create new BPEL project Create new BPEL process Close editor that opened. Open .bpel file by doubleclicking You get warning with stacktrace in error log
    • Similar Issues:
      Show 10 results 
    1. .log
      8 kB
      Libor Zoubek

      Activity

      Brian Fitzpatrick
      added a comment -

      Bob can you look into this and disposition it to Beta2 or beyond?

      Show
      Brian Fitzpatrick
      added a comment - Bob can you look into this and disposition it to Beta2 or beyond?
      Robert (Bob) Brodt
      added a comment -

      I'm unable to repro this. Please list all of the views and editors that are currently open in your workbench, including fast views, and which perspective was currently displayed. Is this O.S. specific?

      Show
      Robert (Bob) Brodt
      added a comment - I'm unable to repro this. Please list all of the views and editors that are currently open in your workbench, including fast views, and which perspective was currently displayed. Is this O.S. specific?
      Libor Zoubek
      added a comment -

      I have opened BPEL Perspective with 'Error Log' view, no other editor. It seems to be a problem of perspective. After I reproduce it and expand 'Window -> Open Perspective' menu, I don't see Perspectives as usual, menu is almost empty. The perspective icon disappears too.

      I'll try to reproduce it on some win tomorrow (if it will be still relevant)

      Show
      Libor Zoubek
      added a comment - I have opened BPEL Perspective with 'Error Log' view, no other editor. It seems to be a problem of perspective. After I reproduce it and expand 'Window -> Open Perspective' menu, I don't see Perspectives as usual, menu is almost empty. The perspective icon disappears too. I'll try to reproduce it on some win tomorrow (if it will be still relevant)
      Feng Qian
      added a comment -

      I try to test again. It works fine. Can't reproduce.

      Show
      Feng Qian
      added a comment - I try to test again. It works fine. Can't reproduce.
      Robert (Bob) Brodt
      added a comment -

      I'm finally able to reliably reproduce this one - should have a fix shortly.

      Show
      Robert (Bob) Brodt
      added a comment - I'm finally able to reliably reproduce this one - should have a fix shortly.
      Robert (Bob) Brodt
      added a comment -

      Fixed: just needed to run updateActions() asynchronously to prevent recursive update

      Show
      Robert (Bob) Brodt
      added a comment - Fixed: just needed to run updateActions() asynchronously to prevent recursive update
      Libor Zoubek
      added a comment -

      Verified on 3.2.0.v20101029-2053-H154-Beta2

      Show
      Libor Zoubek
      added a comment - Verified on 3.2.0.v20101029-2053-H154-Beta2

        People

        • Assignee:
          Robert (Bob) Brodt
          Reporter:
          Libor Zoubek
        • Votes:
          0 Vote for this issue
          Watchers:
          0 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved: