Uploaded image for project: 'Tools (JBoss Tools)'
  1. Tools (JBoss Tools)
  2. JBIDE-25452

Server adapter editor: "Enable debugging" and key are not displayed correctly

    Details

      Description

      steps:

      1. ASSERT: make sure that you have a service running in OpenShift (ex. via creating an app using the nodejs-mongo-persistent template)
      2. ASSERT: make sure that you DONT have a server adapter for it
      3. EXEC: launch server adapter wizard for your service and
      • uncheck "Enable Debugging" > "use image provided key"
      • provide a value for "Key"

      1. ASSERT: server adapter is created
      2. ASSERT: if you inspect the environment variables for the service you'll see that the key and value for it are set:
      3. EXEC: open the server adapter editor and inspect "Enable Debugging" checkbox and "Key" for it

      Result:
      "Enable Debugging" checkbox is CHECKED, there's NO VALUE for "Key"
      Unable to render embedded object: File (server-editor-enable-debugging) not found.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  adietish André Dietisheim
                  Reporter:
                  adietish André Dietisheim
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: