Uploaded image for project: 'Tools (JBoss Tools)'
  1. Tools (JBoss Tools)
  2. JBIDE-22152

Server Adapter, Debugging: Unknown launch is left in Debug view after deletion of an OS 3 server adapter

    Details

    • Sprint:
      devex #116 June 2016
    • Story Points:
      15
    • Steps to Reproduce:
      Hide

      ASSERT: Have an OS3 connection with an application and Eclipse project.
      EXEC: Create a server adapter for Eclipse project and the application on OpenShift.
      ASSERT: There is a launch in Debug view with label of OS3 server adapter.
      EXEC: Delete the OS3 server adapter from Servers view.

      RESULT: There is an unknown launch in Debug view.
      EXPECTED RESULT: Launch in Debug view is removed as well.

      Show
      ASSERT: Have an OS3 connection with an application and Eclipse project. EXEC: Create a server adapter for Eclipse project and the application on OpenShift. ASSERT: There is a launch in Debug view with label of OS3 server adapter. EXEC: Delete the OS3 server adapter from Servers view. RESULT: There is an unknown launch in Debug view. EXPECTED RESULT: Launch in Debug view is removed as well.

      Description

      When I create a new OS3 Server adapter, it also creates a launch in Debug view. If debugging is triggered on an OS3 Server adapter it creates another launch in Debug view with debug icon. When the OS3 Server adapter is removed, its launches stay in Debug view as Unknown and it is not possible to remove them.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  jeffmaury Jeff MAURY
                  Reporter:
                  mlabuda Marián Labuda
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  4 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: