Uploaded image for project: 'Tools (JBoss Tools)'
  1. Tools (JBoss Tools)
  2. JBIDE-15466

org.jboss.tools.aerogear.hybrid.ui depends on org.eclipse.wst.jsdt.core;bundle-version="[1.1.0,1.2.0)" but Kepler SR1 contains version 1.3.0.v201308282108

    Details

      Description

      The updated Kepler SR1 target platform [1] contains a new version of WTP, including org.eclipse.wst.jsdt.core_1.3.0.v201308282108.jar.
      The previous Kepler R target platform [2] contains an older version of WTP, including org.eclipse.wst.jsdt.core_1.1.202.v201208171701.jar.

      Therefore, since the new version falls outside the accepted range in cordova/plugins/org.jboss.tools.aerogear.hybrid.ui/META-INF/MANIFEST.MF - [1.1.0,1.2.0) - the resulting plugin cannot be installed into the JBT aggregate site when built using the Kepler SR1 target platform.

      Instead, we get this:

      [ERROR] Cannot resolve project dependencies:
      [ERROR]   Software being installed: org.jboss.tools.site.core raw:4.1.1.'SNAPSHOT'/format(n[.n=0;[.n=0;[-S]]]):4.1.1-SNAPSHOT
      [ERROR]   Missing requirement: org.jboss.tools.aerogear.hybrid.ui 1.0.0.Alpha1-v20130906-1455-B35 requires 'bundle org.eclipse.wst.jsdt.core [1.1.0,1.2.0)' but it could not be found
      [ERROR]   Cannot satisfy dependency: org.jboss.tools.aerogear.hybrid.feature.feature.group 1.0.0.Alpha1-v20130906-1455-B35 depends on: org.jboss.tools.aerogear.hybrid.ios.ui [1.0.0.Alpha1-v20130906-1455-B35]
      [ERROR]   Cannot satisfy dependency: org.jboss.tools.aerogear.hybrid.feature.source.feature.group 1.0.0.Alpha1-v20130906-1455-B35 depends on: org.jboss.tools.aerogear.hybrid.feature.feature.group [1.0.0.Alpha1-v20130906-1455-B35]
      [ERROR]   Cannot satisfy dependency: org.jboss.tools.aerogear.hybrid.ios.ui 1.0.0.Alpha1-v20130906-1455-B35 depends on: bundle org.jboss.tools.aerogear.hybrid.ui 1.0.0
      [ERROR]   Cannot satisfy dependency: org.jboss.tools.site.core raw:4.1.1.'SNAPSHOT'/format(n[.n=0;[.n=0;[-S]]]):4.1.1-SNAPSHOT depends on: org.jboss.tools.aerogear.hybrid.feature.source.feature.group 0.0.0
      [ERROR] 
      [ERROR] Internal error: java.lang.RuntimeException: "No solution found because the problem is unsatisfiable.": ["Unable to satisfy dependency from org.jboss.tools.aerogear.hybrid.ui 1.0.0.Alpha1-v20130906-1455-B35 to bundle org.eclipse.wst.jsdt.core [1.1.0,1.2.0).", "No solution found because the problem is unsatisfiable."] -> [Help 1]

      [1] http://download.jboss.org/jbosstools/targetplatforms/jbosstoolstarget/4.31.0.Alpha1/REPO/plugins/
      [2] http://download.jboss.org/jbosstools/targetplatforms/jbosstoolstarget/4.30.5.Final/REPO/plugins/

      Solution should be to update the MANIFEST.MF to allow a wider range of upstream plugins:

      - org.eclipse.wst.jsdt.core;bundle-version="[1.1.0,1.2.0)",
      + org.eclipse.wst.jsdt.core;bundle-version="[1.1.0,2.0.0)",
      

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  gercan Gorkem Ercan
                  Reporter:
                  nickboldt Nick Boldt
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: