Details

      Description

      The version of Birt we build against does not match with version for Kepler and conflicts on ICU4j

      https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/DevStudio/view/DevStudio_Trunk/job/jbosstools-4.1_trunk.install-tests-eclipseLatest-jbt_trunk/lastCompletedBuild/testReport/org.jboss.tools.tests.installation/InstallTest/testInstall/
      says:

      Could not install from: http://download.jboss.org/jbosstools/updates/nightly/core/trunk/
      Cannot complete the install because of a conflicting dependency.
      Software being installed: JBoss BIRT Integration 1.4.0.Alpha1-v20130128-1419-B356 (org.jboss.tools.birt.feature.feature.group 1.4.0.Alpha1-v20130128-1419-B356)
      Software currently installed: Eclipse IDE for Java EE Developers 2.0.0.20121218-0936 (epp.package.jee 2.0.0.20121218-0936)
      Only one of the following can be installed at once:
      International Components for Unicode for Java (ICU4J) 4.4.2.v20110823 (com.ibm.icu 4.4.2.v20110823)
      International Components for Unicode for Java (ICU4J) 50.1.0.v20121116-2 (com.ibm.icu 50.1.0.v20121116-2)
      Cannot satisfy dependency:
      From: Eclipse IDE for Java EE Developers 2.0.0.20121218-0936 (epp.package.jee 2.0.0.20121218-0936)
      To: org.eclipse.epp.package.jee.feature.feature.group [2.0.0.20121218-0936]
      Cannot satisfy dependency:
      From: BIRT Chart Framework 4.2.1.v20120820-828i7EFQCnvK_6wFGvqLR (org.eclipse.birt.chart.feature.group 4.2.1.v20120820-828i7EFQCnvK_6wFGvqLR)
      To: org.eclipse.birt.core [4.2.1.v201209121203]
      Cannot satisfy dependency:
      From: BIRT Core Package 4.2.1.v201209121203 (org.eclipse.birt.core 4.2.1.v201209121203)
      To: package com.ibm.icu.lang [3.4.4,5.0.0)
      Cannot satisfy dependency:
      From: Eclipse e4 Rich Client Platform 1.1.0.v20121210-193513-9gFTdGWGGGduU3t_iBdO01nz-4 (org.eclipse.e4.rcp.feature.group 1.1.0.v20121210-193513-9gFTdGWGGGduU3t_iBdO01nz-4)
      To: com.ibm.icu [50.1.0.v20121116-2]
      Cannot satisfy dependency:
      From: Java EE IDE Feature 2.0.0.20121218-0936 (org.eclipse.epp.package.jee.feature.feature.group 2.0.0.20121218-0936)
      To: org.eclipse.platform.feature.group [4.3.0.v20121210-194028-9PF7VHLnG0BBkXvb-5n61JdBeLn2Lmpr5BVxLP]
      Cannot satisfy dependency:
      From: Eclipse Platform 4.3.0.v20121210-194028-9PF7VHLnG0BBkXvb-5n61JdBeLn2Lmpr5BVxLP (org.eclipse.platform.feature.group 4.3.0.v20121210-194028-9PF7VHLnG0BBkXvb-5n61JdBeLn2Lmpr5BVxLP)
      To: org.eclipse.rcp.feature.group [4.3.0.v20121212-184727-7IAUA7Bs-QiyWqWVNz0_nT4qjCeP]
      Cannot satisfy dependency:
      From: Eclipse RCP 4.3.0.v20121212-184727-7IAUA7Bs-QiyWqWVNz0_nT4qjCeP (org.eclipse.rcp.feature.group 4.3.0.v20121212-184727-7IAUA7Bs-QiyWqWVNz0_nT4qjCeP)
      To: org.eclipse.e4.rcp.feature.group [1.1.0.v20121210-193513-9gFTdGWGGGduU3t_iBdO01nz--4]
      Cannot satisfy dependency:
      From: JBoss BIRT Integration 1.4.0.Alpha1-v20130128-1419-B356 (org.jboss.tools.birt.feature.feature.group 1.4.0.Alpha1-v20130128-1419-B356)
      To: org.eclipse.birt.chart.feature.group 2.5.0

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  nickboldt Nick Boldt
                  Reporter:
                  mickael_istria Mickael Istria
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: