Uploaded image for project: 'Tools (JBoss Tools)'
  1. Tools (JBoss Tools)
  2. JBIDE-11549

Support running JBT/JBDS on Eclipse Juno (4.2) platform

    Details

      Description

      Juno is coming - This year, lets see if we can stay compatible. There should be a compatibility layer so unless we use changed internal API's we should be fine.

      If you have a plugin that does not compile/work then we should investigate what options we got - trying to avoid having to maintain two forks!

      Eclipse migration tips: http://dev.eclipse.org/viewcvs/viewvc.cgi/org.eclipse.platform.doc.isv/porting/3.8/incompatibilities.html?revision=1.1&view=co
      (not sure that being empty can be all true)

      WTP help for old friends: http://wiki.eclipse.org/New_Help_for_Old_Friends_VII

      See JBIDE-8624 for last years Indigo move.

      Please link related Juno to this issue and if we find issues please outline the fix and if relevant relate eclipse bugzilla references.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  maxandersen Max Rydahl Andersen
                  Reporter:
                  maxandersen Max Rydahl Andersen
                • Votes:
                  1 Vote for this issue
                  Watchers:
                  6 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: