Details

      Description

      The AS build currently bundles Maven version 3.0-beta-1. There is a sporadic issue that occurs because of a missing pom for ws-commons:policy in the central Maven repository. Maven 3.0 seems to resolve this issue so the build should be updated to use this version.

      The error message is pasted below:

      [ERROR] Failed to execute goal on project jboss-as-iiop: Unable to get dependency information for ws-commons:policy:jar:1.0: Failed to retrieve POM for ws-commons:policy:jar:1.0: Failure to resolve ws-commons/policy/1.0/policy-1.0.pom from http://repository.jboss.org/nexus/content/groups/public/ was cached in the local repository. Resolution will not be reattempted until the update interval of jboss-public-repository-group has elapsed or updates are forced. Original error:
      ws-commons:policy:pom:1.0

      from the specified remote repositories:
      jboss-public-repository-group (http://repository.jboss.org/nexus/content/groups/public/, releases=true, snapshots=true),
      central (http://repo1.maven.org/maven2, releases=true, snapshots=false)
      -> [Help 1]

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  pgier Paul Gier
                  Reporter:
                  pgier Paul Gier
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  0 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: