Application Server 3  4  5 and 6
  1. Application Server 3 4 5 and 6
  2. JBAS-7070

EJB3 version check should be based on JBossMetaData.isEJB3x()

    Details

    • Type: Bug Bug
    • Status: Closed Closed (View Workflow)
    • Priority: Major Major
    • Resolution: Done
    • Affects Version/s: JBossAS-5.1.0.GA
    • Fix Version/s: 6.0.0.M1
    • Component/s: EJB
    • Security Level: Public (Everyone can see)
    • Labels:
      None
    • Similar Issues:
      Show 10 results 

      Description

      org.jboss.ejb3.deployers.Ejb3Deployer does it this way: !(metaData.isEJB2x() || metaData.isEJB1x()). Instead, it should use metaData.isEJB3x(). This is inspired by JBMETA-208.

        Issue Links

          Activity

          Hide
          Alexey Loubyansky
          added a comment -

          Done.

          Show
          Alexey Loubyansky
          added a comment - Done.

            People

            • Assignee:
              Alexey Loubyansky
              Reporter:
              Alexey Loubyansky
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: