Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Done
    • Affects Version/s: JBossAS-5.0.0.CR2
    • Fix Version/s: 6.0.0.M1
    • Component/s: JMX
    • Labels:
    • Environment:

      JBossAS-5 CR2, Sun Java 1.5, Windows 2003

      Description

      Displaying of JBoss MBeans in JConsole as explained here http://www.jboss.org/community/docs/DOC-10521 , no longer works because of the classpath issue. Maybe related to the refactoring of org\jboss\system\server\jmx* classes into jboss-system-jmx.jar in JBoss-5.

      More details about this issue can be found in the linked forum thread.

        Gliffy Diagrams

          Issue Links

            Activity

            surrealskiller V R added a comment -

            These modification to JAVA_OPTS would break run.sh script on Linux.
            Namely, the block that checks if java is 64-bit is executing "java $JAVA_OPTS -version | grep -i 64-bit"
            Adding -Djavax.management.builder.initial=org.jboss.system.server.jmx.MBeanServerBuilderImpl would cause "ClassNotFound" exception because the class is in 'run.jar' which is not loaded at that command.
            As result "java.library.path" would point to wrong location.
            The fix is to remove $JAVA_OPTS from that checking command and specifically check for "-d32" or "-d64" .

            --vr

            hgomez Henri Gomez added a comment -

            I tried to add LazyMBeanServer.class and MBeanServerBuilderImpl.class into a new jar (fix-jb-jmx.jar).

            Archive:  fix-jb-jmx.jar
                testing: org/jboss/system/server/jmx/LazyMBeanServer.class   OK
                testing: org/jboss/system/server/jmx/MBeanServerBuilderImpl.class   OK
            

            I updated run.conf to get it installed :

            JAVA_OPTS="$JAVA_OPTS -Dcom.sun.management.jmxremote.port=8098 -Dcom.sun.management.jmxremote.authenticate=false -Dcom.sun.management.jmxremote.ssl=false -Djboss.platform.mbeanserver"
            JBOSS_CLASSPATH="/Users/henri/jboss-as/bin/fix-jb-jmx.jar"
            

            No more luck :

            2:12:36,089 INFO  [JMXKernel] Legacy JMX core initialized
            12:12:38,091 ERROR [AbstractKernelController] Error installing to Configured: name=ServiceBindingManager state=Configured
            java.lang.Exception: Error calling callback JMXRegistrationAdvice for target context ServiceBindingManager
            	at org.jboss.dependency.plugins.AbstractLifecycleCallbackItem.install(AbstractLifecycleCallbackItem.java:91)
            	at org.jboss.dependency.plugins.AbstractController.handleLifecycleCallbacks(AbstractController.java:1589)
            	at org.jboss.dependency.plugins.AbstractController.handleInstallLifecycleCallbacks(AbstractController.java:1554)
            	at org.jboss.dependency.plugins.AbstractController.incrementState(AbstractController.java:947)
            	at org.jboss.dependency.plugins.AbstractController.resolveContexts(AbstractController.java:1082)
            	at org.jboss.dependency.plugins.AbstractController.resolveContexts(AbstractController.java:988)
            	at org.jboss.dependency.plugins.AbstractController.install(AbstractController.java:778)
            	at org.jboss.dependency.plugins.AbstractController.install(AbstractController.java:543)
            	at org.jboss.deployers.vfs.deployer.kernel.BeanMetaDataDeployer.deploy(BeanMetaDataDeployer.java:125)
            	at org.jboss.deployers.vfs.deployer.kernel.BeanMetaDataDeployer.deploy(BeanMetaDataDeployer.java:52)
            	at org.jboss.deployers.spi.deployer.helpers.AbstractSimpleRealDeployer.internalDeploy(AbstractSimpleRealDeployer.java:62)
            	at org.jboss.deployers.spi.deployer.helpers.AbstractRealDeployer.deploy(AbstractRealDeployer.java:55)
            	at org.jboss.deployers.plugins.deployers.DeployerWrapper.deploy(DeployerWrapper.java:179)
            	at org.jboss.deployers.plugins.deployers.DeployersImpl.doDeploy(DeployersImpl.java:1454)
            	at org.jboss.deployers.plugins.deployers.DeployersImpl.doInstallParentFirst(DeployersImpl.java:1172)
            	at org.jboss.deployers.plugins.deployers.DeployersImpl.doInstallParentFirst(DeployersImpl.java:1193)
            	at org.jboss.deployers.plugins.deployers.DeployersImpl.install(DeployersImpl.java:1113)
            	at org.jboss.dependency.plugins.AbstractControllerContext.install(AbstractControllerContext.java:348)
            	at org.jboss.dependency.plugins.AbstractController.install(AbstractController.java:1652)
            	at org.jboss.dependency.plugins.AbstractController.incrementState(AbstractController.java:938)
            	at org.jboss.dependency.plugins.AbstractController.resolveContexts(AbstractController.java:1082)
            	at org.jboss.dependency.plugins.AbstractController.resolveContexts(AbstractController.java:988)
            	at org.jboss.dependency.plugins.AbstractController.change(AbstractController.java:826)
            	at org.jboss.dependency.plugins.AbstractController.change(AbstractController.java:556)
            	at org.jboss.deployers.plugins.deployers.DeployersImpl.process(DeployersImpl.java:789)
            	at org.jboss.deployers.plugins.main.MainDeployerImpl.process(MainDeployerImpl.java:699)
            	at org.jboss.system.server.profileservice.repository.MainDeployerAdapter.process(MainDeployerAdapter.java:117)
            	at org.jboss.system.server.profileservice.repository.ProfileDeployAction.install(ProfileDeployAction.java:70)
            	at org.jboss.system.server.profileservice.repository.AbstractProfileAction.install(AbstractProfileAction.java:53)
            	at org.jboss.system.server.profileservice.repository.AbstractProfileService.install(AbstractProfileService.java:403)
            	at org.jboss.dependency.plugins.AbstractControllerContext.install(AbstractControllerContext.java:348)
            	at org.jboss.dependency.plugins.AbstractController.install(AbstractController.java:1652)
            	at org.jboss.dependency.plugins.AbstractController.incrementState(AbstractController.java:938)
            	at org.jboss.dependency.plugins.AbstractController.resolveContexts(AbstractController.java:1082)
            	at org.jboss.dependency.plugins.AbstractController.resolveContexts(AbstractController.java:988)
            	at org.jboss.dependency.plugins.AbstractController.install(AbstractController.java:778)
            	at org.jboss.dependency.plugins.AbstractController.install(AbstractController.java:543)
            	at org.jboss.system.server.profileservice.repository.AbstractProfileService.registerProfile(AbstractProfileService.java:308)
            	at org.jboss.system.server.profileservice.ProfileServiceBootstrap.start(ProfileServiceBootstrap.java:256)
            	at org.jboss.bootstrap.AbstractServerImpl.start(AbstractServerImpl.java:461)
            	at org.jboss.Main.boot(Main.java:221)
            	at org.jboss.Main$1.run(Main.java:556)
            	at java.lang.Thread.run(Thread.java:680)
            Caused by: javax.management.InstanceNotFoundException: JMImplementation:type=MBeanRegistry
            	at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.getMBean(DefaultMBeanServerInterceptor.java:1094)
            	at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.invoke(DefaultMBeanServerInterceptor.java:833)
            	at com.sun.jmx.mbeanserver.JmxMBeanServer.invoke(JmxMBeanServer.java:761)
            	at org.jboss.system.microcontainer.jmx.ServiceControllerRegistrationLifecycleCallback.install(ServiceControllerRegistrationLifecycleCallback.java:96)
            	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
            	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
            	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
            	at java.lang.reflect.Method.invoke(Method.java:597)
            	at org.jboss.reflect.plugins.introspection.ReflectionUtils.invoke(ReflectionUtils.java:59)
            	at org.jboss.reflect.plugins.introspection.ReflectMethodInfoImpl.invoke(ReflectMethodInfoImpl.java:150)
            	at org.jboss.joinpoint.plugins.BasicMethodJoinPoint.dispatch(BasicMethodJoinPoint.java:66)
            	at org.jboss.beans.info.plugins.AbstractBeanInfo.invoke(AbstractBeanInfo.java:300)
            	at org.jboss.kernel.plugins.dependency.AbstractKernelControllerContext.invoke(AbstractKernelControllerContext.java:291)
            	at org.jboss.dependency.plugins.AbstractLifecycleCallbackItem.install(AbstractLifecycleCallbackItem.java:87)
            	... 42 more
            12:12:38,498 ERROR [AbstractKernelController] Error installing to Instantiated: name=jboss.system:service=MainDeployer state=Described mode=Manual requiredState=Configured
            javax.management.InstanceNotFoundException: JMImplementation:type=MBeanRegistry
            	at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.getMBean(DefaultMBeanServerInterceptor.java:1094)
            	at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.invoke(DefaultMBeanServerInterceptor.java:833)
            	at com.sun.jmx.mbeanserver.JmxMBeanServer.invoke(JmxMBeanServer.java:761)
            	at org.jboss.system.ServiceCreator.installPlainMBean(ServiceCreator.java:217)
            	at org.jboss.system.ServiceCreator.install(ServiceCreator.java:130)
            	at org.jboss.system.microcontainer.InstantiateAction.installAction(InstantiateAction.java:45)
            	at org.jboss.system.microcontainer.InstantiateAction.installAction(InstantiateAction.java:37)
            	at org.jboss.dependency.plugins.action.SimpleControllerContextAction.simpleInstallAction(SimpleControllerContextAction.java:62)
            	at org.jboss.dependency.plugins.action.AccessControllerContextAction.install(AccessControllerContextAction.java:71)
            	at org.jboss.dependency.plugins.AbstractControllerContextActions.install(AbstractControllerContextActions.java:51)
            	at org.jboss.dependency.plugins.AbstractControllerContext.install(AbstractControllerContext.java:348)
            	at org.jboss.system.microcontainer.ServiceControllerContext.install(ServiceControllerContext.java:297)
            	at org.jboss.dependency.plugins.AbstractController.install(AbstractController.java:1652)
            	at org.jboss.dependency.plugins.AbstractController.incrementState(AbstractController.java:938)
            	at org.jboss.dependency.plugins.AbstractController.resolveContexts(AbstractController.java:1082)
            	at org.jboss.dependency.plugins.AbstractController.resolveContexts(AbstractController.java:988)
            	at org.jboss.dependency.plugins.AbstractController.change(AbstractController.java:826)
            	at org.jboss.dependency.plugins.AbstractController.change(AbstractController.java:556)
            	at org.jboss.system.ServiceController.doChange(ServiceController.java:688)
            	at org.jboss.system.ServiceController.install(ServiceController.java:274)
            	at org.jboss.system.deployers.ServiceDeployer.deploy(ServiceDeployer.java:90)
            	at org.jboss.system.deployers.ServiceDeployer.deploy(ServiceDeployer.java:46)
            	at org.jboss.deployers.spi.deployer.helpers.AbstractSimpleRealDeployer.internalDeploy(AbstractSimpleRealDeployer.java:62)
            	at org.jboss.deployers.spi.deployer.helpers.AbstractRealDeployer.deploy(AbstractRealDeployer.java:55)
            	at org.jboss.deployers.plugins.deployers.DeployerWrapper.deploy(DeployerWrapper.java:179)
            	at org.jboss.deployers.plugins.deployers.DeployersImpl.doDeploy(DeployersImpl.java:1454)
            	at org.jboss.deployers.plugins.deployers.DeployersImpl.doInstallParentFirst(DeployersImpl.java:1172)
            	at org.jboss.deployers.plugins.deployers.DeployersImpl.doInstallParentFirst(DeployersImpl.java:1193)
            	at org.jboss.deployers.plugins.deployers.DeployersImpl.install(DeployersImpl.java:1113)
            	at org.jboss.dependency.plugins.AbstractControllerContext.install(AbstractControllerContext.java:348)
            	at org.jboss.dependency.plugins.AbstractController.install(AbstractController.java:1652)
            	at org.jboss.dependency.plugins.AbstractController.incrementState(AbstractController.java:938)
            	at org.jboss.dependency.plugins.AbstractController.resolveContexts(AbstractController.java:1082)
            	at org.jboss.dependency.plugins.AbstractController.resolveContexts(AbstractController.java:988)
            	at org.jboss.dependency.plugins.AbstractController.change(AbstractController.java:826)
            	at org.jboss.dependency.plugins.AbstractController.change(AbstractController.java:556)
            	at org.jboss.deployers.plugins.deployers.DeployersImpl.process(DeployersImpl.java:789)
            	at org.jboss.deployers.plugins.main.MainDeployerImpl.process(MainDeployerImpl.java:699)
            	at org.jboss.system.server.profileservice.repository.MainDeployerAdapter.process(MainDeployerAdapter.java:117)
            	at org.jboss.system.server.profileservice.repository.ProfileDeployAction.install(ProfileDeployAction.java:70)
            	at org.jboss.system.server.profileservice.repository.AbstractProfileAction.install(AbstractProfileAction.java:53)
            	at org.jboss.system.server.profileservice.repository.AbstractProfileService.install(AbstractProfileService.java:403)
            	at org.jboss.dependency.plugins.AbstractControllerContext.install(AbstractControllerContext.java:348)
            	at org.jboss.dependency.plugins.AbstractController.install(AbstractController.java:1652)
            	at org.jboss.dependency.plugins.AbstractController.incrementState(AbstractController.java:938)
            	at org.jboss.dependency.plugins.AbstractController.resolveContexts(AbstractController.java:1082)
            	at org.jboss.dependency.plugins.AbstractController.resolveContexts(AbstractController.java:988)
            	at org.jboss.dependency.plugins.AbstractController.install(AbstractController.java:778)
            	at org.jboss.dependency.plugins.AbstractController.install(AbstractController.java:543)
            	at org.jboss.system.server.profileservice.repository.AbstractProfileService.registerProfile(AbstractProfileService.java:308)
            	at org.jboss.system.server.profileservice.ProfileServiceBootstrap.start(ProfileServiceBootstrap.java:256)
            	at org.jboss.bootstrap.AbstractServerImpl.start(AbstractServerImpl.java:461)
            	at org.jboss.Main.boot(Main.java:221)
            	at org.jboss.Main$1.run(Main.java:556)
            	at java.lang.Thread.run(Thread.java:680)
            12:12:38,502 ERROR [AbstractKernelController] Error installing to Real: name=vfsfile:/Users/henri/Downloads/jboss-eap-5.1/jboss-as/server/default/conf/jboss-service.xml state=PreReal mode=Manual requiredState=Real
            org.jboss.deployers.spi.DeploymentException: Error deploying: jboss.system:service=MainDeployer
            

            What could be wrong ?

            hgomez Henri Gomez added a comment -

            Adding -Djavax.management.builder.initial=org.jboss.system.server.jmx.MBeanServerBuilderImpl in JAVA_OPTS make it works but only in localhost. I can't connect from another box

            fdrouet Frederic DROUET added a comment -

            try to add also -Djava.rmi.server.hostname=$(hostname) to be able to connect remotely
            (ensure that hostname command give the correct full hostname of the remote server)

            hgomez Henri Gomez added a comment -

            Tried this but hostname should be a fully domain name (ie: mymachine.mysite.com). I turned to use IP address instead


              People

              • Assignee:
                smarlow Scott Marlow
                Reporter:
                jaikiran jaikiran pai
              • Votes:
                4 Vote for this issue
                Watchers:
                11 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Development