Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: JBossAS-5.0.0.Beta2
    • Fix Version/s: JBossAS-5.0.0.Beta4
    • Component/s: None
    • Labels:
      None
    • Environment:
      Windows

      Description

      An out-of-the-box installation of JBoss 5.0.0 Beta2 running with JDK 1.6 produces the following exception upon startup. Not sure the whys or wherefores but am pretty sure its not a good thing.

      13:24:13,467 INFO [ServerImpl] Starting JBoss (Microcontainer)...
      13:24:13,467 INFO [ServerImpl] Release ID: JBoss [Morpheus] 5.0.0.Beta2 (build: SVNTag=JBoss_5_0_0_Beta2 date=200704060017)
      13:24:13,467 INFO [ServerImpl] Home Dir: C:\Program Files\jboss-5.0.0.Beta2
      13:24:13,467 INFO [ServerImpl] Home URL: file:/C:/Program Files/jboss-5.0.0.Beta2/
      13:24:13,467 INFO [ServerImpl] Library URL: file:/C:/Program Files/jboss-5.0.0.Beta2/lib/
      13:24:13,467 INFO [ServerImpl] Patch URL: null
      13:24:13,467 INFO [ServerImpl] Server Name: default
      13:24:13,467 INFO [ServerImpl] Server Home Dir: C:\Program Files\jboss-5.0.0.Beta2\server\default
      13:24:13,467 INFO [ServerImpl] Server Home URL: file:/C:/Program Files/jboss-5.0.0.Beta2/server/default/
      13:24:13,467 INFO [ServerImpl] Server Data Dir: C:\Program Files\jboss-5.0.0.Beta2\server\default\data
      13:24:13,467 INFO [ServerImpl] Server Temp Dir: C:\Program Files\jboss-5.0.0.Beta2\server\default\tmp
      13:24:13,467 INFO [ServerImpl] Server Config URL: file:/C:/Program Files/jboss-5.0.0.Beta2/server/default/conf/
      13:24:13,467 INFO [ServerImpl] Server Library URL: file:/C:/Program Files/jboss-5.0.0.Beta2/server/default/lib/
      13:24:13,467 INFO [ServerImpl] Root Deployment Filename: jboss-service.xml
      13:24:13,499 INFO [ServerImpl] Starting Microcontainer, bootstrapURL=file:/C:/Program Files/jboss-5.0.0.Beta2/server/default/conf/bootstrap-beans.xml
      13:24:14,831 INFO [ProfileImpl] Using profile root:C:\Program Files\jboss-5.0.0.Beta2\server\default
      13:24:15,913 ERROR [AbstractKernelController] Error installing to Instantiated: name=DeploymentFilter state=Described
      java.lang.IllegalStateException: Class not found: [Ljava.lang.String;
      at org.jboss.metadata.spi.signature.Signature.stringsToClasses(Signature.java:174)
      at org.jboss.metadata.spi.signature.Signature.stringsToClasses(Signature.java:125)
      at org.jboss.metadata.spi.signature.Signature.getParametersTypes(Signature.java:292)
      at org.jboss.metadata.plugins.loader.reflection.AnnotatedElementMetaDataLoader.getComponentMetaDataRetrieval(AnnotatedElementMetaDataLoader.java:138)
      at org.jboss.metadata.plugins.context.AbstractMetaDataContext.getComponentMetaDataRetrieval(AbstractMetaDataContext.java:280)
      at org.jboss.metadata.spi.retrieval.MetaDataRetrievalToMetaDataBridge.getComponentMetaData(MetaDataRetrievalToMetaDataBridge.java:159)
      at org.jboss.aop.microcontainer.integration.AOPConstructorJoinpoint.methodHasAnnotations(AOPConstructorJoinpoint.java:202)
      at org.jboss.aop.microcontainer.integration.AOPConstructorJoinpoint.hasMethodMetaData(AOPConstructorJoinpoint.java:172)
      at org.jboss.aop.microcontainer.integration.AOPConstructorJoinpoint.hasInstanceOrJoinpointMetaData(AOPConstructorJoinpoint.java:152)
      at org.jboss.aop.microcontainer.integration.AOPConstructorJoinpoint.dispatch(AOPConstructorJoinpoint.java:99)
      at org.jboss.kernel.plugins.dependency.KernelControllerContextAction.dispatchJoinPoint(KernelControllerContextAction.java:103)
      at org.jboss.kernel.plugins.dependency.InstantiateAction.installActionInternal(InstantiateAction.java:52)
      at org.jboss.kernel.plugins.dependency.KernelControllerContextAction.installAction(KernelControllerContextAction.java:197)
      at org.jboss.kernel.plugins.dependency.KernelControllerContextAction.install(KernelControllerContextAction.java:136)
      at org.jboss.dependency.plugins.AbstractControllerContextActions.install(AbstractControllerContextActions.java:51)
      at org.jboss.dependency.plugins.AbstractControllerContext.install(AbstractControllerContext.java:233)
      at org.jboss.dependency.plugins.AbstractController.install(AbstractController.java:724)
      at org.jboss.dependency.plugins.AbstractController.incrementState(AbstractController.java:445)
      at org.jboss.dependency.plugins.AbstractController.resolveContexts(AbstractController.java:555)
      at org.jboss.dependency.plugins.AbstractController.resolveContexts(AbstractController.java:489)
      at org.jboss.dependency.plugins.AbstractController.install(AbstractController.java:289)
      at org.jboss.dependency.plugins.AbstractController.install(AbstractController.java:192)
      at org.jboss.kernel.plugins.deployment.AbstractKernelDeployer.deployBean(AbstractKernelDeployer.java:302)
      at org.jboss.kernel.plugins.deployment.AbstractKernelDeployer.deployBeans(AbstractKernelDeployer.java:272)
      at org.jboss.kernel.plugins.deployment.AbstractKernelDeployer.deploy(AbstractKernelDeployer.java:119)
      at org.jboss.kernel.plugins.deployment.BasicKernelDeployer.deploy(BasicKernelDeployer.java:64)
      at org.jboss.kernel.plugins.deployment.xml.BasicXMLDeployer.deploy(BasicXMLDeployer.java:76)
      at org.jboss.kernel.plugins.deployment.xml.BasicXMLDeployer.deploy(BasicXMLDeployer.java:146)
      at org.jboss.system.server.profileservice.ProfileServiceBootstrap.deploy(ProfileServiceBootstrap.java:295)
      at org.jboss.system.server.profileservice.ProfileServiceBootstrap.bootstrap(ProfileServiceBootstrap.java:222)
      at org.jboss.kernel.plugins.bootstrap.AbstractBootstrap.run(AbstractBootstrap.java:89)
      at org.jboss.system.server.profileservice.ServerImpl.doStart(ServerImpl.java:403)
      at org.jboss.system.server.profileservice.ServerImpl.start(ServerImpl.java:342)
      at org.jboss.Main.boot(Main.java:210)
      at org.jboss.Main$1.run(Main.java:522)
      at java.lang.Thread.run(Unknown Source)
      Caused by: java.lang.ClassNotFoundException: [Ljava.lang.String;
      at java.net.URLClassLoader$1.run(Unknown Source)
      at java.security.AccessController.doPrivileged(Native Method)
      at java.net.URLClassLoader.findClass(Unknown Source)
      at java.lang.ClassLoader.loadClass(Unknown Source)
      at java.lang.ClassLoader.loadClass(Unknown Source)
      at org.jboss.metadata.spi.signature.Signature.stringsToClasses(Signature.java:170)
      ... 35 more
      13:24:16,258 INFO [ServerInfo] Java version: 1.6.0,Sun Microsystems Inc.
      13:24:16,258 INFO [ServerInfo] Java VM: Java HotSpot(TM) Client VM 1.6.0-b105,Sun Microsystems Inc.
      13:24:16,258 INFO [ServerInfo] OS-System: Windows XP 5.1,x86
      13:24:16,305 INFO [JMXKernel] Legacy JMX core initialized
      Failed to boot JBoss:
      java.lang.RuntimeException: Exception during Bootstrap
      at org.jboss.kernel.plugins.bootstrap.AbstractBootstrap.run(AbstractBootstrap.java:99)
      at org.jboss.system.server.profileservice.ServerImpl.doStart(ServerImpl.java:403)
      at org.jboss.system.server.profileservice.ServerImpl.start(ServerImpl.java:342)
      at org.jboss.Main.boot(Main.java:210)
      at org.jboss.Main$1.run(Main.java:522)
      at java.lang.Thread.run(Unknown Source)
      Caused by: org.jboss.deployers.spi.IncompleteDeploymentException: Summary of incomplete deployments (SEE PREVIOUS ERRORS FOR DETAILS):

          • CONTEXTS MISSING DEPENDENCIES: Name -> Dependency {Required State:Actual State}

      VFSBootstrapScanner
      -> DeploymentFilter

      {Configured:**ERROR**}

      VFSDeployerScanner
      -> DeploymentFilter

      {Configured:**ERROR**}

      VFSDeploymentScanner
      -> DeploymentFilter

      {Configured:**ERROR**}
          • CONTEXTS IN ERROR: Name -> Error

      DeploymentFilter -> java.lang.ClassNotFoundException: [Ljava.lang.String;

      at org.jboss.system.server.profileservice.ProfileServiceBootstrap.checkIncomplete(ProfileServiceBootstrap.java:389)
      at org.jboss.system.server.profileservice.ProfileServiceBootstrap.bootstrap(ProfileServiceBootstrap.java:236)
      at org.jboss.kernel.plugins.bootstrap.AbstractBootstrap.run(AbstractBootstrap.java:89)
      ... 5 more

        Gliffy Diagrams

          Issue Links

            Activity

            rolandbali Roland Bali added a comment -

            This might be obvious since it seems to be a 1.6 bug but the error persists on JDK 1.6.0_03-b05 in Windows.

            jason.greene Jason Greene added a comment -

            I posted this specific JDK problem's details, workaround and solution in June:
            http://lists.jboss.org/pipermail/jboss-development/2007-June/009714.html

            starksm64 Scott Stark added a comment -

            From Jason's post:
            There is an undocumented system property (besides the jvm source) in JDK
            5 and 6 called "sun.lang.ClassLoader.allowArraySyntax". The default
            changed from true to false in JDK6. So what this means is that in JDK6,
            unless you set that property to true, if you try and load a Java array
            type using a classloader (e.g. "[[B") you will get a CNFE.

            The compatible solution is to either interpret array types directly (not
            hard), or to use the extended form of Class.forName(), which does
            understand the array syntax:

            Class clazz = Class.forName(className, false, loader);

            dimitris Dimitris Andreadis added a comment -

            Link to issue for making AS5 run under Java6.

            asoldano Alessio Soldano added a comment -

            The current trunk compile and startup fine with JDK 1.6, just tried with version 1.6.0_04-b12.


              People

              • Assignee:
                asoldano Alessio Soldano
                Reporter:
                gzoller Greg Zoller
              • Votes:
                18 Vote for this issue
                Watchers:
                15 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Development