Application Server 3  4  5 and 6
  1. Application Server 3 4 5 and 6
  2. JBAS-1226

shutdown misses org/jboss/system/server/ServerImpl

    Details

    • Similar Issues:
      Show 10 results 

      Description

      SourceForge Submitter: andd .
      Something has changed in the packaging and the
      ServerImpl class cannot be found:

      X:\cvs\jboss-public\jboss-head\build\output\jboss-
      5.0.0alpha\bin>shutdown -s jnp
      ://localhost:1099
      Exception in thread "main"
      java.lang.NoClassDefFoundError: org/jboss/system/serv
      er/ServerImpl
      at org.jboss.Shutdown.main(Unknown Source)
      Press any key to continue . . .

      It affects shutdown from the command line or through
      the test scripts.

        Activity

        Hide
        Dimitris Andreadis
        added a comment -

        Logged In: YES
        user_id=583305

        Instead of changing the packaging, turned the dependency
        from class org.jboss.system.server.ServerImpl to interface
        ServerImplMBean

        Show
        Dimitris Andreadis
        added a comment - Logged In: YES user_id=583305 Instead of changing the packaging, turned the dependency from class org.jboss.system.server.ServerImpl to interface ServerImplMBean
        Hide
        Johnny Walker
        added a comment -

        I ran into this issue with a fresh download of 4.2.3GA recently. I found the fix at the forums:

        http://www.jboss.org/index.html?module=bb&op=viewtopic&t=146991&view=previous

        Basically edit your jboss_init.sh script to include the client/jbossall-client.jar in the $JBOSSCP for the shutdown command.

        So mine looks like this:

        #define the classpath for the shutdown class
        #JBOSSCP=$

        {JBOSSCP:-"$JBOSS_HOME/bin/shutdown.jar:$JBOSS_HOME/client/jnet.jar"}

        JBOSSCP=$

        {JBOSSCP:-"$BINARY_HOME/client/jbossall-client.jar:$JBOSS_HOME/bin/shutdown.jar"}

        I don't know where this jnet.jar is coming from either - that file doesn't exist on my system so I removed it.

        Show
        Johnny Walker
        added a comment - I ran into this issue with a fresh download of 4.2.3GA recently. I found the fix at the forums: http://www.jboss.org/index.html?module=bb&op=viewtopic&t=146991&view=previous Basically edit your jboss_init.sh script to include the client/jbossall-client.jar in the $JBOSSCP for the shutdown command. So mine looks like this: #define the classpath for the shutdown class #JBOSSCP=$ {JBOSSCP:-"$JBOSS_HOME/bin/shutdown.jar:$JBOSS_HOME/client/jnet.jar"} JBOSSCP=$ {JBOSSCP:-"$BINARY_HOME/client/jbossall-client.jar:$JBOSS_HOME/bin/shutdown.jar"} I don't know where this jnet.jar is coming from either - that file doesn't exist on my system so I removed it.

          People

          • Assignee:
            Dimitris Andreadis
            Reporter:
            SourceForge legacy user
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: