Uploaded image for project: 'Fuse Tools'
  1. Fuse Tools
  2. FUSETOOLS-590

Cannot connect to MQ broker container from fabric explorer

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 2.1.0
    • Component/s: None
    • Labels:
      None
    • Environment:
      2.1.351

      Description

      I created a fabric on my local machine.

      I then created some child containers, such as a mq profile.

      From Fuse IDE I can connect to the various containers, and use the terminal, and so forth.

      However the JMX view of the broker container does not work.
      I can do the JMX view on a Camel example profile, and that works fine.

      I get a class not found exception for the broker.

      java.lang.NoClassDefFoundError: org/apache/activemq/broker/jmx/QueueViewMBean
      	at com.fusesource.ide.fabric.activemq.navigator.ActiveMQNodeProvider$1.run(ActiveMQNodeProvider.java:54)
      	at com.fusesource.ide.fabric.navigator.jmx.FabricConnectionWrapper$1.doWithJmxConnector(FabricConnectionWrapper.java:162)
      	at org.fusesource.fabric.service.JmxTemplate.execute(JmxTemplate.java:47)
      	at com.fusesource.ide.fabric.navigator.jmx.FabricConnectionWrapper.run(FabricConnectionWrapper.java:158)
      	at com.fusesource.ide.fabric.activemq.navigator.ActiveMQNodeProvider.provide(ActiveMQNodeProvider.java:49)
      	at com.fusesource.ide.jmx.core.tree.NodeUtils.enrichRootNode(NodeUtils.java:85)
      	at com.fusesource.ide.jmx.core.tree.NodeUtils.createObjectNameTree(NodeUtils.java:77)
      	at com.fusesource.ide.fabric.navigator.jmx.FabricConnectionWrapper.loadRoot(FabricConnectionWrapper.java:129)
      	at com.fusesource.ide.fabric.navigator.jmx.FabricConnectionWrapper.loadChildren(FabricConnectionWrapper.java:145)
      	at com.fusesource.ide.fabric.navigator.jmx.FabricConnectionWrapper.loadChildren(FabricConnectionWrapper.java:141)
      	at com.fusesource.rider.commons.tree.RefreshableNode.refresh(RefreshableNode.java:20)
      	at com.fusesource.ide.fabric.navigator.jmx.FabricConnectionWrapper.connect(FabricConnectionWrapper.java:91)
      	at com.fusesource.ide.jmx.core.ConnectJob.run(ConnectJob.java:32)
      	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
      Caused by: java.lang.ClassNotFoundException: org.apache.activemq.broker.jmx.QueueViewMBean
      	at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:513)
      	at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:429)
      	at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:417)
      	at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:107)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
      	... 14 more

        Gliffy Diagrams

          Issue Links

            Activity

            davsclaus Claus Ibsen added a comment -

            I get the exception, when I right click on the JMX in the broker1 -> JMX in the Fabric Explorer, and select connect.
            Normally Fuse IDE will auto connect if you select the JMX node, as it shows a little expand triangle, that you just open.

            lhein Lars Heinemann added a comment -

            should be fixed now with James latest patch.


              People

              • Assignee:
                lhein Lars Heinemann
                Reporter:
                davsclaus Claus Ibsen
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: