Uploaded image for project: 'Fuse Tooling'
  1. Fuse Tooling
  2. FUSETOOLS-1918

Deploying and undeploying to a server in the Servers view not always successful

    Details

    • Sprint:
      8.0.0 - Beta3
    • Steps to Reproduce:
      Hide
      1. Create a new Fuse 6.2.1 server in the Servers view.
      2. Create a new Fuse project with the CBR template. Use your Fuse server in the facet.
      3. Start the server.
      4. Deploy the project via right-click on server and Add/Remove.
      5. Look in the Terminal to make sure it was deployed (osgi:list).
      6. Now remove it - either right click on the project in the servers view and select Remove or go back to the server context menu, select Add/Remove, and remove it that way.
      7. Look in the Terminal to make sure it was removed (osgi:list).
      Show
      Create a new Fuse 6.2.1 server in the Servers view. Create a new Fuse project with the CBR template. Use your Fuse server in the facet. Start the server. Deploy the project via right-click on server and Add/Remove. Look in the Terminal to make sure it was deployed (osgi:list). Now remove it - either right click on the project in the servers view and select Remove or go back to the server context menu, select Add/Remove, and remove it that way. Look in the Terminal to make sure it was removed (osgi:list).

      Description

      While working on project templates I've hit upon some weirdness with deploying and undeploying Fuse projects to a Fuse server in the Servers view.

      1. Create a new Fuse 6.2.1 server in the Servers view.
      2. Create a new Fuse project with the CBR template. Use your Fuse server in the facet.
      3. Start the server.
      4. Deploy the project via right-click on server and Add/Remove.
      5. Look in the Terminal to make sure it was deployed (osgi:list).
      6. Now remove it - either right click on the project in the servers view and select Remove or go back to the server context menu, select Add/Remove, and remove it that way.
      7. Look in the Terminal to make sure it was removed (osgi:list).

      I'm finding that things are NOT undeploying using the Servers view. You have to explicitly do an "uninstall #" where # is the bundle id # for your project.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                tsedmik Tomáš Sedmík
                Reporter:
                bfitzpat Brian Fitzpatrick
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: