Uploaded image for project: 'Forge'
  1. Forge
  2. FORGE-671

Forge plugin should warn when installing a plugin that depends on non-PROVIDED forge internal artifacts

    Details

    • Type: Enhancement
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 1.0.6.Final
    • Fix Version/s: 1.1.0.Final
    • Component/s: Plugin API
    • Labels:
      None

      Description

      JBoss Forge, version [ 1.0.7-SNAPSHOT ] - JBoss, by Red Hat, Inc. [ http://jboss.org/forge ]
      Connecting to remote repository [https://raw.github.com/forge/plugin-repository/master/repository.yaml]... connected!
      ***INFO*** Preparing to install plugin: undo
      ***INFO*** Checking out plugin source files to [/var/folders/rl/rjr7dgvs5pb5ksbclhlf_n6m0000gn/T/forgetemp5959951326220048671/repo] via 'git'
      ***INFO*** Switching to branch/tag [refs/heads/master]
      ***ERROR*** Plugin has a dependency on internal Forge API [org.jboss.forge:forge-git-tools:jar::] - this is not allowed and may cause failures.
      ***INFO*** Invoking build with underlying build system.
      [INFO] Scanning for projects...
      

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                lincolnthree Lincoln Baxter III
                Reporter:
                lincolnthree Lincoln Baxter III
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: