Uploaded image for project: 'Forge'
  1. Forge
  2. FORGE-1596

Forge doesn't discover JVM properly on OS X

    Details

    • Type: Enhancement
    • Status: Closed (View Workflow)
    • Priority: Trivial
    • Resolution: Done
    • Affects Version/s: 2.0.0.Final
    • Fix Version/s: 2.1.0.Final
    • Component/s: UI - Shell
    • Labels:
      None
    • Environment:

      OS X / Mavericks, with both java 1.6 and 1.7 installed

      Description

      When running a fresh Forge 2.0.0.Final CLI, I observer this:

      $ forge
      Using Forge at /Users/tair/forge-distribution-2.0.0.Final
       Error: a Java 1.7 or higher JRE is required to run Forge; found [/System/Library/Frameworks/JavaVM.framework/Versions/CurrentJDK/Home/bin/java -version == java version "1.6.0_65"
      Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-11M4609)
      Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)].
      

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                tair.sabirgaliev Tair Sabirgaliev
                Reporter:
                tair.sabirgaliev Tair Sabirgaliev
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: