Uploaded image for project: 'Red Hat Fuse'
  1. Red Hat Fuse
  2. ENTESB-10308

Wrong artifact version for pax-jdbc-postgresql comes with Fuse 7.2

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: fuse-7.2
    • Fix Version/s: fuse-7.3
    • Component/s: Karaf
    • Labels:
      None
    • Environment:
      • Red Hat Fuse 7.2
      • karaf container runtime
    • Sprint:
      Fuse 7.3 Sprint 42 - Bug fix

      Description

      Although "Red Hat Fuse Supported Configurations"(1) says "JDBC 4.2 Postgresql Driver, Version 9" is certified, JDBC 4.1 driver is specified in the
      $FUSE_HOME/system/org/ops4j/pax/jdbc/pax-jdbc-features/1.3.0/pax-jdbc-features-1.3.0-features.xml as follows:

          <feature name="pax-jdbc-postgresql" description="Provides JDBC PostgreSQL DataSourceFactory" version="1.3.0">
              <feature>pax-jdbc-spec</feature>
      
              <bundle dependency="true">mvn:org.apache.geronimo.specs/geronimo-jta_1.1_spec/1.1.1</bundle>
              <bundle>mvn:org.postgresql/postgresql/9.4.1212.jre7</bundle>
          </feature>
      

      version 9.4.1212.jre7 is the one for JDBC 4.1.
      (1) https://access.redhat.com/articles/310603#Red-Hat-Fuse-72

      https://jdbc.postgresql.org/download.html
      On the site, please click the link "9.4.1212 JDBC 42", then you will get postgresql-9.4.1212.jar.
      9.4.1212.jre7 is the one for "9.4.1212 JDBC 41"

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                grgrzybek Grzegorz Grzybek
                Reporter:
                hisao.furuichi Hisao Furuichi
                Tester:
                Tomas Turek
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: