Application Server 7
  1. Application Server 7
  2. AS7-4115

Jboss Web Connector resources max-threads data not available in ui or cli/json data

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved (View Workflow)
    • Priority: Critical Critical
    • Resolution: Won't Fix Won't Fix
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
    • Environment:
      Using JBEAP-6.0.0.ER1.
    • Estimated Difficulty:
      High
    • Steps to Reproduce:

      Browse JBoss Web component via Ui or cli and look for max-threads.

      Show
      Browse JBoss Web component via Ui or cli and look for max-threads.
    • Similar Issues:
      Show 10 results 

      Description

      Looks like max-threads is not currently exposed for JBoss Web Connectors.

      "connector" => {"http" =>

      { "bytesReceived" => "0", "bytesSent" => "0", "enable-lookups" => false, "enabled" => true, "errorCount" => "0", "max-post-size" => 2097152, "max-save-post-size" => 4096, "maxTime" => "0", "processingTime" => "0", "protocol" => "HTTP/1.1", "redirect-port" => 8443, "requestCount" => "0", "scheme" => "http", "secure" => false, "socket-binding" => "http", "ssl" => undefined, "virtual-server" => undefined }

      }

        Activity

        Emanuel Muckenhuber
        added a comment -

        I think the attribute you are looking for is max-connections. There is no max-threads anymore. Assigning to jean-frederic to validate.

        Show
        Emanuel Muckenhuber
        added a comment - I think the attribute you are looking for is max-connections. There is no max-threads anymore. Assigning to jean-frederic to validate.
        Jean-Frederic Clere
        added a comment -

        See:
        [standalone@localhost:9999 connector=http] :read-resource
        {
        "outcome" => "success",
        "result" => {
        "enable-lookups" => false,
        "enabled" => true,
        "executor" => undefined,
        "max-connections" => undefined,

        Show
        Jean-Frederic Clere
        added a comment - See: [standalone@localhost:9999 connector=http] :read-resource { "outcome" => "success", "result" => { "enable-lookups" => false, "enabled" => true, "executor" => undefined, "max-connections" => undefined,
        Heiko Rupp
        added a comment -

        The :read-resource-description says "depends on connector", but the concrete connector instance fails to deliver a value.

        Either make this return a value, or add something to the resource-connection. Otherwise users don't know the default.

        Show
        Heiko Rupp
        added a comment - The :read-resource-description says "depends on connector", but the concrete connector instance fails to deliver a value. Either make this return a value, or add something to the resource-connection. Otherwise users don't know the default.
        Jean-Frederic Clere
        added a comment - - edited

        That is nearly impossible to fix the default is in jbossweb connector logic there is no easy way get it in the resource logic.

        Show
        Jean-Frederic Clere
        added a comment - - edited That is nearly impossible to fix the default is in jbossweb connector logic there is no easy way get it in the resource logic.
        Heiko Rupp
        added a comment -

        Can you please then tell us what the normal default is when as7 is delivered? 45 or 123 or maxInt?

        Show
        Heiko Rupp
        added a comment - Can you please then tell us what the normal default is when as7 is delivered? 45 or 123 or maxInt?
        Jean-Frederic Clere
        added a comment -

        512 * number of cpu cores for JIO.
        32 * number of cpu cores for APR.

        Show
        Jean-Frederic Clere
        added a comment - 512 * number of cpu cores for JIO. 32 * number of cpu cores for APR.
        Heiko Rupp
        added a comment -

        There seems more metrics missing:

        • Current Active Threads
        • Current Thread Count
        • Maximum Threads
        Show
        Heiko Rupp
        added a comment - There seems more metrics missing: Current Active Threads Current Thread Count Maximum Threads
        Jean-Frederic Clere
        added a comment -

        Those 3 values make no sense when using an executor, additionally Current Active Threads / Current Thread Count would require jbossweb to expose them in the protocol (*Protocol.java).

        Show
        Jean-Frederic Clere
        added a comment - Those 3 values make no sense when using an executor, additionally Current Active Threads / Current Thread Count would require jbossweb to expose them in the protocol (*Protocol.java).
        Remy Maucherat
        added a comment -

        This will not be addressed, because the necessary APIs are not exposed at the moment in web. Additionally, the three attributes are meaningless once an executor is configured and will mislead a user. I would recommend defaulting to an executor (which has a small performance impact, but the performance testers could be allowed to remove it and use the max performance mode).

        Show
        Remy Maucherat
        added a comment - This will not be addressed, because the necessary APIs are not exposed at the moment in web. Additionally, the three attributes are meaningless once an executor is configured and will mislead a user. I would recommend defaulting to an executor (which has a small performance impact, but the performance testers could be allowed to remove it and use the max performance mode).

          People

          • Assignee:
            Jean-Frederic Clere
            Reporter:
            Simeon Pinder
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: