Uploaded image for project: 'Arquillian'
  1. Arquillian
  2. ARQ-2201

arquillian-container-karaf-managed can not start the karaf server with JDK9+

    Details

    • Type: Bug
    • Status: Open (View Workflow)
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: OSGi Containers
    • Labels:
      None

      Description

      Karaf support the JDK9+ since 4.2.0 but when starting with the arquillian the error is

      -Djava.endorsed.dirs=/path/to/apache-karaf-minimal-4.2.0/lib/endorsed is not supported.
      

      The possible fix could be with KarafManagedDeployableContainer.java and should not pass the "-Dendorsed" argument when the JDK version >= 9

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  Unassigned
                  Reporter:
                  zhfeng Zheng Feng
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated: