Release Notes - Errai - Version 3.1.0.CR1 - HTML format

Component Upgrade

  • [ERRAI-755] - Use Wildlfy 8 for Demos
  • [ERRAI-770] - Use WildFly8 per default in Errai tutorial project

Enhancement

  • [ERRAI-756] - Change Forge Addon to setup projects with Wildfly 8
  • [ERRAI-777] - There should be a way of specifying which LESS stylesheets are to be compiled

Feature Request

  • [ERRAI-589] - Explore using GWT's incremental generator for the MarshallerFactoryImpl
  • [ERRAI-713] - Upgrade to Weld 2 / CDI 1.1
  • [ERRAI-736] - Provide an ErraiBus WebSocket endpoint for WildFly/Undertow
  • [ERRAI-740] - Provide a custom linker to generate permutation(user-agent) specific cache manifest files
  • [ERRAI-748] - Allow for flexible URL design in Errai Navigation
  • [ERRAI-751] - Support secure websockets scheme
  • [ERRAI-760] - Guava version used by Errai is incompatible with JDK 1.8
  • [ERRAI-766] - Implement the destroy() method in javax.enterprise.inject.Instance

Bug

  • [ERRAI-700] - Improper use of CDI SPI by Errai's CDI extension
  • [ERRAI-754] - Broken pipe on logout on WildFly 8
  • [ERRAI-758] - Server-side security interceptors not triggered for @RestrictedAccess on interface type
  • [ERRAI-759] - StandardAsyncServlet throws exceptions on Jetty
  • [ERRAI-761] - Message Bus doesn't marshal exceptions thrown in server-side @Services
  • [ERRAI-762] - Inconsistent behaviour between server- and client-side security interceptors
  • [ERRAI-763] - Bean Validation causes NPE for bindable types with uninitialized collection fields
  • [ERRAI-764] - Errai hanging during shutdown
  • [ERRAI-765] - ListWidget removes widgets from the UI panel but does not destroy them.
  • [ERRAI-769] - Less variable import fails
  • [ERRAI-772] - Backoff logic doesn't work for SSE
  • [ERRAI-773] - Errai JAX-RS does not set domain for @CookieParams
  • [ERRAI-778] - can not start Visual Bus Monitor in errai-tutorial thru gwt-maven-plugin way
  • [ERRAI-779] - Errai UI Template fails to load some template fragments with no specified root on GWT 2.6.1
  • [ERRAI-782] - ContextualProviderInjector NPE for classes without generic
  • [ERRAI-783] - org.jboss.errai.security.server.ServerSecurityRoleInterceptor

Task

  • [ERRAI-731] - Investigate SSO Integration
  • [ERRAI-732] - Investigate Fine-Grained Authorization Rules for Errai Security
  • [ERRAI-734] - Upgrade to Picketlink 2.6.0.Final
  • [ERRAI-768] - Upgrade Errai to GWT 2.6.1
  • [ERRAI-771] - Consolidate all version numbers to properties in errai-parent
  • [ERRAI-774] - Add SuperDevMode instructions to tutorial and reference guide
  • [ERRAI-775] - Use GWT 2.6.1 for Errai 3.1.x setup with Forge addon
  • [ERRAI-776] - Only Configure errai-bom for dependency management with Forge addon if Errai version is 3.1.x

Edit/Copy Release Notes

The text area below allows the project release notes to be edited and copied to another document.