Details

    • Type: Story
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Sprint:
      Sprint 52, Sprint 55, Sprint 59, Sprint 60, Sprint 61, Sprint 62, Sprint 63, Sprint 64

      Description

      related PR to start from: https://github.com/windup/windup/pull/1321 --> Forge/Furnace dependencies have been updated there.

      we need to be able to run on JDK11 and 8.

      • web console / openshift: upgrade jboss modules
      • core: upgrade janusgraph to 0.3.0 (on the PR its a snapshot version, but it's likely it will be available in maven central soon, at least the sources are released according to github)
      • from a quick test on JDK10 byte-buddy (we inherit it from ferma) needs to be updated too, as the version we are using (1.7.5) doesn't know java10 and above: https://github.com/raphw/byte-buddy/issues/370

      trial and error from there.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  mrizzi Marco Rizzi
                  Reporter:
                  janinee Janine Eichler
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: