Uploaded image for project: 'WildFly'
  1. WildFly
  2. WFLY-87

Fired object messages violate classloaders

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Out of Date
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: JMS
    • Labels:
      None
    • Similar Issues:
      Show 10 results 

      Description

      JMS allows you to fire an object message. In this case, I have a object of type in my deployment. It fires fine. I bind a message consumer to a queue in AS7. the object message coming in results in a classloader violation:

      22:13:35,116 ERROR [org.jboss.seam.jms.example.statuswatcher.messagedriven.DistributorMDB] (Thread-2 (group:HornetQ-client-global-threads-767046602)) org.jboss.seam.jms.example.statuswatcher.model.Status from [Module "org.hornetq:main" from local module loader @19d009b4 (roots: /apps/jboss-as-7.0.0.Final/modules)]: javax.jms.JMSException: org.jboss.seam.jms.example.statuswatcher.model.Status from [Module "org.hornetq:main" from local module loader @19d009b4 (roots: /apps/jboss-as-7.0.0.Final/modules)]
      at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:191)
      at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:358)
      at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:330)
      at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:307)
      at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:101)
      at java.lang.Class.forName0(Native Method) [:1.6.0_22]
      at java.lang.Class.forName(Class.java:247) [:1.6.0_22]
      at java.io.ObjectInputStream.resolveClass(ObjectInputStream.java:603) [:1.6.0_22]
      at org.hornetq.utils.ObjectInputStreamWithClassLoader.resolveClass(ObjectInputStreamWithClassLoader.java:69) [hornetq-core-2.2.6.Final.jar:]
      at java.io.ObjectInputStream.readNonProxyDesc(ObjectInputStream.java:1574) [:1.6.0_22]
      at java.io.ObjectInputStream.readClassDesc(ObjectInputStream.java:1495) [:1.6.0_22]
      at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1731) [:1.6.0_22]
      at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1328) [:1.6.0_22]
      at java.io.ObjectInputStream.readObject(ObjectInputStream.java:350) [:1.6.0_22]
      at org.hornetq.jms.client.HornetQObjectMessage.getObject(HornetQObjectMessage.java:158) [hornetq-jms-2.2.6.Final.jar:]
      at org.jboss.seam.jms.example.statuswatcher.messagedriven.DistributorMDB.onMessage(DistributorMDB.java:46)
      at org.hornetq.jms.client.JMSMessageListenerWrapper.onMessage(JMSMessageListenerWrapper.java:91) [hornetq-jms-2.2.6.Final.jar:]
      at org.hornetq.core.client.impl.ClientConsumerImpl.callOnMessage(ClientConsumerImpl.java:866) [hornetq-core-2.2.6.Final.jar:]
      at org.hornetq.core.client.impl.ClientConsumerImpl.access$100(ClientConsumerImpl.java:44) [hornetq-core-2.2.6.Final.jar:]
      at org.hornetq.core.client.impl.ClientConsumerImpl$Runner.run(ClientConsumerImpl.java:983) [hornetq-core-2.2.6.Final.jar:]
      at org.hornetq.utils.OrderedExecutorFactory$OrderedExecutor$1.run(OrderedExecutorFactory.java:100) [hornetq-core-2.2.6.Final.jar:]
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) [:1.6.0_22]
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) [:1.6.0_22]
      at java.lang.Thread.run(Thread.java:662) [:1.6.0_22]

        Gliffy Diagrams

          Issue Links

            Activity

            jmesnil Jeff Mesnil added a comment -

            Rasto Cesnekthanks for the report.

            I think you are hitting a separate issue that's not directly related to the messaging subsystem. From a servlet, I am not able to deserialize a Document instance that I just created and serialized. We're talking about in on JBoss dev mailing list[1]

            [1] http://lists.jboss.org/pipermail/jboss-as7-dev/2012-July/006377.html

            erce Rasto Cesnek added a comment -

            Thanks for pointing, I didn't even dare to think the problem is this deep Serializing and deserializing Document does not work in the WAR module nor in the EJB module.

            jaikiran jaikiran pai added a comment - - edited

            There hasn't been an update on the reproducibility of this issue against latest nightly builds. As a result, this issue has been moved around to different target/fix versions. I think we should just resolve this as out-of-date. If this is still an issue against the latest release WildFly version or the nightly build, please provide a relevant application which reproduces it.

            meetoblivion John Ament added a comment -

            I'll actually give this a try in the wfly builds shortly (probably this weekend). I think the bypass for this is to use jboss-deployment-structure.xml in the deployment now (since this was originally noted in AS6 and kind of just brought along for the ride).

            jaikiran jaikiran pai added a comment -

            John, I'll close this for now. Please reopen or create a new JIRA if you get a chance to reproduce this against a latest released WildFly version. Thank you!


              People

              • Assignee:
                jmesnil Jeff Mesnil
                Reporter:
                meetoblivion John Ament
              • Votes:
                8 Vote for this issue
                Watchers:
                16 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Development