WildFly
  1. WildFly
  2. WFLY-873

Arquillian throws OutOfMemoryError: PermGen space after deploying several big wars on JBoss 7

    Details

    • Type: Bug Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor Minor
    • Resolution: Out of Date Out of Date
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Test Suite
    • Labels:
    • Similar Issues:
      Show 10 results 

      Description

      Here's the proof (that build is saved forever):
      https://hudson.qa.jboss.com/hudson/view/Drools%20jBPM/job/guvnor/1161/console
      Our war is apparently so big, that the 3th deployment fails with PermGen.

      A few tests later it even hangs forever (until it times out)

      10:41:56,393 ERROR [org.apache.catalina.core.ContainerBase.[jboss.web].[default-host].[/dc25ad71-9358-412e-8a90-c4471cb3422f].[ArquillianServletRunner]] (http--127.0.0.1-8080-2) Servlet.service() for servlet ArquillianServletRunner threw exception: java.lang.OutOfMemoryError: PermGen space
      

      How to reproduce?
      =================

      git clone git@github.com:droolsjbpm/guvnor.git guvnor
      cd guvnor
      mvn clean install -DskipTests
      cd guvnor-webapp
      gedit src/test/resources/arquillian.xml
      // remove the maxTestClassesBeforeRestart property
      mvn test

      Using arquillian 1.0.0.CR5 and jboss 7.0.2.

      Workaround: use maxTestClassesBeforeRestart = 1.

        Gliffy Diagrams

          Activity

          jay shaughnessy added a comment -

          It looks like we're seeing this as well on the JON/RHQ project. We have a smaller test EAR that deploys only an EJB jar and a few jars to /lib, and this deployment does not have the problem. But a larger deployment with two EJB jars, a SAR and a lot of 3rd party jars (no WARs fwiw) hits it fairly quickly, after 2-3 deployments.

          I have not tried the workaround yet. Also, we're trying to set up a single deployment for multiple test classes. If that works then that may be a separate workaround.

          Andrew Rubinger added a comment -

          Updated link to the build which is failing, or the stack trace? Are we sure it's Arquillian with some CL leak; deploying directly to AS7/Wildfly a number of times does not yield the same problem?

          Geoffrey De Smet added a comment -

          Guvnor has been renamed/rewritten as drools-wb. The arquillian tests did not made the transition (yet) I think, check with Michael Anstis. (I am full-time on OptaPlanner now.)
          The guvnor 5.5.x branch should build correctly: https://github.com/droolsjbpm/guvnor/tree/5.5.x
          But I can't promise if it's not a dead end for reproducing this issue decently.

          Feel free to close this issue as out-of-date.


            People

            • Assignee:
              Andrew Rubinger
              Reporter:
              Geoffrey De Smet
            • Votes:
              2 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development