Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 8.0.0.Final
    • Component/s: None
    • Labels:
      None
    • Environment:
      Grails 1.3.4 and 2.0
    • Steps to Reproduce:

      Download grails.
      grails create-app my-project
      cd my-project
      grails war

      copy war to jboss.
      Try and go to my-project in browser.

      Show
      Download grails. grails create-app my-project cd my-project grails war copy war to jboss. Try and go to my-project in browser.

      Description

      When deploying any Grails 1.3.4 or 2.0 project with Jboss 7 final version, the Grails project deploys properly but
      the gsp pages in the project will not actually be loaded by the Jboss server.
      There are not errors listed in the server log.
      I am aware of this bug https://issues.jboss.org/browse/AS7-2941, which of course displays errors,
      but with the new 7.1.0 final versions no errors are displayed.

        Gliffy Diagrams

          Activity

          hsn10 Radim Kolář added a comment -

          Even if i deleted all OSGi stuff from MANIFEST, i still got same error as listed above for app build with grails 2.0.4. I was not able to get this app running. It works nicely on Glassfish.

          hsn10 Radim Kolář added a comment -

          Actually it seems that grails spring-security-core is to blame because plain grails hello world app deploys and runs fine on 7.1.3-SNAPSHOT.

          mkappeller Matthias Kappeller added a comment -

          Are there any news on this bug? I encounter the exact same error as Radim.

          swd847 Stuart Douglas added a comment -

          This is unlikely to be fixed unless someone creates a reproducer for the bug.

          ctomc Tomaz Cerar added a comment -

          This should be fixed in WildFly 8, given that we dont ship OSGI subsystem anymore.


            People

            • Assignee:
              Unassigned
              Reporter:
              thebravedave David Pugh
            • Votes:
              1 Vote for this issue
              Watchers:
              8 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development