Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Rejected
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Test Suite
    • Labels:
      None

      Description

      Post-7.1.1 jiras: AS7-4067

      Arquillian tasks affecting the testsuite: https://docspace.corp.redhat.com/docs/DOC-71831

      Maven wishes for summer:

        Gliffy Diagrams

          Issue Links

          1.
          Tests must fail the build by default. Sub-task Closed Ondrej Zizka      
           
          2.
          TS: Compare sets of tests run in both versions for respective groups Sub-task Closed Ondrej Zizka      
           
          3.
          TS: Check regressions Sub-task Closed Ondrej Zizka      
           
          4.
          TS: Implement test reporting. Sub-task Closed Ondrej Zizka      
           
          5.
          TS: Check scripts options. Sub-task Closed Ondrej Zizka      
           
          6.
          TS: Check -Dtest Sub-task Closed Ondrej Zizka      
           
          7.
          TS: Some tests are still in org.jboss.as.testsuite.integration package Sub-task Closed Ondrej Zizka      
           
          8.
          Maven plugin to process properties Sub-task Closed Ondrej Zizka      
           
          9.
          TS: Coverage reports Sub-task Closed Ondrej Zizka      
           
          10.
          build.sh clean install -DallTests doesn't work after scripts were split Sub-task Closed Ondrej Zizka      
           
          11.
          TS: #!/bin/sh prevents using bash construct Sub-task Closed Ondrej Zizka      
           
          12.
          TS: Prepare for merging into master. Sub-task Closed Ondrej Zizka      
           
          13.
          TS: Check clustering and compat and spec tests Sub-task Closed Ondrej Zizka      
           
          14.
          TS: Discuss package names - org.jboss.as.testsuite.integration.xyz vs. org.jboss.as.test.xyz Sub-task Closed Ondrej Zizka      
           
          15.
          TS: Discuss resources location - next to .java files? Sub-task Closed Ondrej Zizka      
           
          16.
          TS: Consolidate documentation of the testsuite. Sub-task Closed Ondrej Zizka      
           
          17.
          TS: Tests grouping Sub-task Resolved Honza Brázdil      
           
          18.
          TS: Add a module for shared util classes. Sub-task Closed Ondrej Zizka      
           
          19.
          TS: Review smoke tests Sub-task Closed Ondrej Zizka      
           
          20.
          TS: Pick the most acceptable test packages organization Sub-task Closed Ondrej Zizka      
           
          21.
          TS: Put all management tests into one dir (org.jboss.as.test.integration.mgmt) Sub-task Resolved Ondrej Zizka      
           
          22.
          Alternative JDKs for building and running - OpenJDK 6, 7, Sun JDK 7, IcedTea Sub-task Closed Ondrej Zizka      
           
          23.
          TS: Get new harness to master. Sub-task Closed Ondrej Zizka      
           
          24.
          TS: Check tests workdirs Sub-task Resolved Ondrej Zizka      
           
          25. TS: Logging issues (tracking) Sub-task Open Ondrej Zizka     Test Suite
           
          26.
          TS: Move Arquillian configs from src/test/resources/X to some special dir. Sub-task Closed Ondrej Zizka      
           
          27.
          TS: Fix -Ddebug (-Djpda) Sub-task Closed Ondrej Zizka      
           
          28.
          TS: IPv6 testing issues (tracking) Sub-task Closed Ondrej Zizka      
           
          29.
          TS: Unify activation properties' names (e.g. -DstressTests instead of -Dstress-test) Sub-task Closed Ondrej Zizka      
           
          30.
          TS: On -Dtest=..., activate appropriate modules automatically (using package prefix) Sub-task Resolved Ondrej Zizka      
           
          31.
          TS: Define testsuite acceptance test (a testsuite for the testsuite) Sub-task Closed Ondrej Zizka      
           
          32.
          TS: `mvn install` and `build.sh` must run smoke tests by default. Sub-task Closed Ondrej Zizka      
           
          33.
          TS: Move smoke and integration tests before the domain stuff. Sub-task Closed Ondrej Zizka      
           
          34.
          TS: Generate server config for Arq instances (standalone-*.xml) using XSLT instead of keeping them in resources. Sub-task Closed Ondrej Zizka      
           
          35. TS: Test output is not stored in ...-output.txt Sub-task Open Ondrej Zizka     Test Suite
           
          36.
          TS: Print help banner on `mvn install` without params. Sub-task Closed Ondrej Zizka      
           
          37.
          Propagate property node0 to system properties Sub-task Closed Ondrej Zizka      
           
          38.
          TS: Add properties "jbossas.ts.integ.dir", "jbossas.ts.dir", "jbossas.project.dir" and use them in test. Sub-task Closed Ondrej Zizka      
           
          39.
          TS: Move *-arquillian.xml from testsuite.integration/src/test/resources/** to some better place. Sub-task Closed Ondrej Zizka      
           
          40.
          TS: Clustering tests - figure out how they will be run Sub-task Resolved Radoslav Husar      
           
          41.
          TS: Hitting max file limit with reporting (`mvn site`) Sub-task Closed Ondrej Zizka      
           
          42.
          TS: (Re-)Create test group for web profile. Sub-task Resolved Unassigned      
           
          43.
          TS: Update windows scripts (build.bat and integration-tests.bat) Sub-task Closed Madhumita Sadhukhan      
           
          44.
          TS: Check tests for hard-coded strings like URLs etc. - candidates for parametrization. Sub-task Resolved Ondrej Zizka      
           
          45.
          TS: Implement self-test. Sub-task Closed Ondrej Zizka

          0%

          Original Estimate - 4 days
          Remaining Estimate - 4 days
             
           
          46.
          TS: Option to run under security manager. Sub-task Resolved Peter Skopek      
           
          47.
          TS: Configurable timeouts Sub-task Closed Ondrej Zizka      
           
          48.
          TS: Option to fail if AS is running (~ a port is open) Sub-task Resolved Ondrej Zizka      
           
          49. TS: Multiple Surefire executions - FAILURE in one supresses successive. Sub-task Open Ondrej Zizka     Test Suite
           
          50.
          TS: Database switch (in datasources) Sub-task Resolved Ondrej Zizka      
           
          51.
          TS: -Djboss.dist=... has no effect, /build/target/jboss-as* is always used Sub-task Closed Ondrej Zizka

          100%

          Original Estimate - 1 week, 2 days Original Estimate - 1 week, 2 days
          Time Spent - 1 week, 3 days
             
           
          52.
          TS: Way to build with a clean local repo. Sub-task Closed Ondrej Zizka      
           
          53.
          TS: Find a way to retain same value of property with ${basedir} in submodules. Sub-task Closed Ondrej Zizka      
           
          54.
          TS: Check endorsed jboss-annotations-api. Sub-task Closed Ondrej Zizka      
           
          55.
          TS: Make commons-lang3, commons-io and commons-codec available in tests. Sub-task Closed Ondrej Zizka      
           
          56.
          TS: Check how JDBC drivers are copied Sub-task Closed Honza Brázdil      
           
          57.
          TS: Make container JVM --enable-assertions configurable. Sub-task Closed Ondrej Zizka

          0%

          Original Estimate - 2 hours
          Remaining Estimate - 2 hours
             
           
          58. TS: Pass the path to docs/examples to the tests. Sub-task Open Ondrej Zizka

          0%

          Original Estimate - 2 hours
          Remaining Estimate - 2 hours
            Test Suite
           
          59.
          TS: Fix XSLT transformations (namespaces problem) Sub-task Closed Ondrej Zizka

          0%

          Original Estimate - 2 days
          Remaining Estimate - 2 days
             
           
          60.
          TS: parametrize surefire test.redirectTestOutputToFile property Sub-task Closed Ondrej Zizka      
           
          61.
          TS: Pass node0, node1 to <ant ...> since inheritAll="true" doesn't work. Sub-task Closed Ondrej Zizka

          0%

          Original Estimate - 2 hours
          Remaining Estimate - 2 hours
             
           
          62.
          TS: Add $managementAddress and $managementPort to all arquillian.xml's. Sub-task Closed Ondrej Zizka

          0%

          Original Estimate - 3 hours
          Remaining Estimate - 3 hours
             
           
          63.
          TS: Script to check missed tests. Sub-task Closed Ondrej Zizka

          0%

          Original Estimate - 1 hour
          Remaining Estimate - 1 hour
             
           
          64.
          TS: Some tests missing from <includes> and are not run. Sub-task Resolved Ondrej Zizka

          0%

          Original Estimate - 3 hours
          Remaining Estimate - 3 hours
             
           
          65.
          TS: Allow debugging client with -DdebugClient (only AS is possible now) Sub-task Resolved Unassigned

          0%

          Original Estimate - 4 hours
          Remaining Estimate - 4 hours
             
           
          66. TS: -Dtest=*<something>* only matches one test per module. Sub-task Reopened Aslak Knutsen     Test Suite
           
          67.
          TS: Implement replacing of ...=localhost in .properties resources Sub-task Resolved Ondrej Zizka

          0%

          Original Estimate - 2 hours
          Remaining Estimate - 2 hours
             
           
          68. TS: Allow XSLT to fit any namespace versions. Sub-task Open Ondrej Zizka

          12%

          Original Estimate - 2 days
          Time Spent - 2 hours Remaining Estimate - 1 day, 6 hours
            Test Suite
           
          69.
          Implement fallback mechanism for AS7 properties in pom.xml Sub-task Closed Pavel Janousek     Test Suite
           
          70. TS: Dynamic way to get ports of various services. Sub-task Open Ondrej Zizka

          0%

          Original Estimate - 1 day
          Remaining Estimate - 1 day
            Test Suite
           
          71.
          TS: API changes report - Animal sniffer maven plugin Sub-task Resolved Ondrej Zizka

          0%

          Original Estimate - 3 days
          Remaining Estimate - 3 days
             
           
          72. TS: Make Surefire test ordering configurable. Sub-task Open Ondrej Zizka

          0%

          Original Estimate - 4 hours
          Remaining Estimate - 4 hours
            Test Suite
           

            Activity

            ozizka Ondrej Zizka added a comment -

            Let's continue in AS7-3122.

            jdcasey John Casey added a comment -

            SUREFIRE-803, SUREFIRE-806, SUREFIRE-809 implemented / fixed, and SUREFIRE-808 closed WONTFIX (since it's obsoleted by -809). We're going to attempt the 2.12 release for Surefire starting by the end of this week.

            jason.greene Jason Greene added a comment -

            This issue is being relocated to 7.1.2 so that 7.1.1 only contains criticals, blockers, and EAP LA issues (which are probably not yet at the right status, or need an extra triage pass).

            If these issues are completed in a 7.1.1 timeframe please change the fix version. Although if you forget I will bulk correct.

            brian.stansberry Brian Stansberry added a comment -

            Use issue labels for this kind of thing.

            rhusar Radoslav Husar added a comment -

            Well, I guess there is to both sides. Issues are easier to throw around, assign, writeup some metadata as opposed to labels. The price is carrying around a dummy task.


              People

              • Assignee:
                ozizka Ondrej Zizka
                Reporter:
                ozizka Ondrej Zizka
              • Votes:
                1 Vote for this issue
                Watchers:
                7 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - 4 weeks, 1 day, 7 hours Original Estimate - 4 weeks, 1 day, 7 hours
                  4w 1d 7h
                  Remaining:
                  Time Spent - 1 week, 3 days, 2 hours Remaining Estimate - 2 weeks, 4 days, 5 hours
                  2w 4d 5h
                  Logged:
                  Time Spent - 1 week, 3 days, 2 hours Remaining Estimate - 2 weeks, 4 days, 5 hours
                  1w 3d 2h

                    Development