Uploaded image for project: 'WildFly'
  1. WildFly
  2. WFLY-4517

Do not expose Infinispan bits to deployments importing the Hibernate main module

    Details

      Description

      This is mainly a follow up to
      https://bugzilla.redhat.com/show_bug.cgi?id=1202911

      But also a consequence of difficulties I had with Hibernate Search (which depends on both latest Infinispan and the Hibernate version in WildFly), and Hibernate OGM (which requires Hibernate ORM but has strong coupling with specific versions of Infinispan).

      The gist of the problem is that the module org.hibernate:main includes the integration code with Infinispan for second level caching.

      While I agree people will want to enable the second level caching, I don't think they should be exposed to it, so I'll propose some changes.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  sannegrinovero Sanne GRINOVERO
                  Reporter:
                  sannegrinovero Sanne GRINOVERO
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  4 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: