Uploaded image for project: 'WildFly'
  1. WildFly
  2. WFLY-3812

Package-private access doesn't work since Weld 2.2.4

    XMLWordPrintable

    Details

      Description

      The WildFly snapshot for 9.0.0.Alpha1 submits the serious warning below, when PicketLink is used. This warning is a result of upgrading to Weld 2.2.4. Please make the fix (at the bottom) before releasing WFLY 9. Thank you.

      WARN  [org.jboss.as.weld] WFLYWELD0052:
      Using deployment classloader to load proxy classes for module org.picketlink.core:main.
      Package-private access will not work. To fix this the module should declare dependencies on [org.jboss.weld.core, org.jboss.weld.spi]
      

      The fix is:
      In file feature-pack/src/main/resources/modules/system/layers/base/org/picketlink/core/main/module.xml add these two lines within the <dependencies> block:

      <module name="org.jboss.weld.core"/>
      <module name="org.jboss.weld.spi"/>
      

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                jharting Jozef Hartinger
                Reporter:
                juergen.zimmermann Juergen Zimmermann
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: