Uploaded image for project: 'JBoss OSGi'
  1. JBoss OSGi
  2. JBOSGI-677

Some javax.* bundles show version 0.0.0 in AS7

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Out of Date
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: wildfly
    • Labels:
      None

      Description

      Some javax bundles that we configure by default do not show valid bundle version info

      javax.jws.api:0.0.0
      javax.ws.rs.api:0.0.0

      The javax.persistence.api has its metadata defined in jbosgi-xservice.properties like this

      Bundle-SymbolicName: hibernate-jpa-2.0-api
      Bundle-Version: 1.0.1.Final
      Export-Package: javax.persistence.spi;version="2.0.0",javax.persistence.criteria;version="2.0.0",javax.persistence;version="2.0.0",javax.persistence.metamodel;version="2.0.0"
      

      This should be replaced by metadata coming from the artefacts manifest.

      Generally, all javax api artefacts should have valid OSGi metadata

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  Unassigned
                  Reporter:
                  thomas.diesler Thomas Diesler
                • Votes:
                  1 Vote for this issue
                  Watchers:
                  5 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: