Uploaded image for project: 'WildFly'
  1. WildFly
  2. WFLY-11587

org.jboss.as.weld has optional dependency on org.jboss.as.security which causes regression

    Details

      Description

      This is originally reported on forums, see this link.
      The post contains a nice reproducer (which should be turned into automated test) along with steps to reproduce.

      The original cause is WFLY-11125 where Weld's dependency on org.jboss.as.security changed from mandatory to optional. This causes failures when using @Inject Principal.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  brian.stansberry Brian Stansberry
                  Reporter:
                  manovotn Matej Novotny
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  5 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: