Uploaded image for project: 'WildFly'
  1. WildFly
  2. WFLY-10252

Upgrade Weld-related modules to JBoss Modules 1.8

    Details

      Description

      Once JBoss Modules 1.8+ hit WFLY (meaning when core gets upgraded to 5.0.0.Alpha3 or newer) we should update all weld-related modules to use this version and change the dependencies to the JDK 9+ style (for instance replacing javax.api dep with various standard modules).

      For more info, see original proposal.
      Or check this email on JBoss modules 1.8 features.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                manovotn Matej Novotny
                Reporter:
                manovotn Matej Novotny
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: