Uploaded image for project: 'WildFly Core'
  1. WildFly Core
  2. WFCORE-4366

Exclude org.apache.commons:commons-lang3 from the elytron-tool

    Details

      Description

      It is only used by model-test and comes in transitively through model-test's dependencies:

      $mvn dependency:tree -pl model-test/
      [INFO] Scanning for projects...
      [INFO]
      [INFO] ----------------< org.wildfly.core:wildfly-model-test >-----------------
      [INFO] Building WildFly: Common Code for Subsystem and Non-subsystem Test Harness 8.0.1.Final-redhat-SNAPSHOT
      [INFO] --------------------------------[ jar ]---------------------------------
      [INFO]
      [INFO] --- maven-dependency-plugin:3.1.1:tree (default-cli) @ wildfly-model-test ---
      [INFO] org.wildfly.core:wildfly-model-test:jar:8.0.1.Final-redhat-SNAPSHOT
      [INFO] +- junit:junit:jar:4.12:compile
      [INFO] |  \- org.hamcrest:hamcrest-core:jar:1.3:compile
      [INFO] +- org.apache.maven:maven-resolver-provider:jar:3.5.0:compile
      [INFO] |  +- org.apache.maven:maven-model:jar:3.5.0:compile
      [INFO] |  +- org.apache.maven:maven-model-builder:jar:3.5.0:compile
      [INFO] |  |  +- org.codehaus.plexus:plexus-interpolation:jar:1.24:compile
      [INFO] |  |  +- org.apache.maven:maven-artifact:jar:3.5.0:compile
      [INFO] |  |  +- org.apache.maven:maven-builder-support:jar:3.5.0:compile
      [INFO] |  |  \- com.google.guava:guava:jar:20.0:compile
      [INFO] |  +- org.apache.maven:maven-repository-metadata:jar:3.5.0:compile
      [INFO] |  +- org.apache.maven.resolver:maven-resolver-impl:jar:1.1.0:compile
      [INFO] |  +- org.codehaus.plexus:plexus-component-annotations:jar:1.7.1:compile
      [INFO] |  \- org.apache.commons:commons-lang3:jar:3.5:compile
      

      This causes a dependency convergence error downstream as there we align to the version of commons-lang3 used in full (3.8) and we end up with the tool pulling in 3.8 and model-test using 3.5. Although there is a wildcard exclusion for all of the elytron tool's dependencies, this does not work due to https://issues.apache.org/jira/browse/MENFORCER-195

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  kabirkhan Kabir Khan
                  Reporter:
                  kabirkhan Kabir Khan
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  1 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: