Uploaded image for project: 'WildFly Core'
  1. WildFly Core
  2. WFCORE-3392

inaccurate error message in validating required attribute with alternatives

    Details

    • Type: Enhancement
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Done
    • Affects Version/s: 4.0.0.Alpha2
    • Fix Version/s: 4.0.0.Alpha3
    • Component/s: Management
    • Labels:
      None

      Description

      This is created based on comments in JBEAP-8666

      failure message is inaccurate and points out only that ssl-context must be defined, it should also mention the security-realm as one of the options.

      /subsystem=undertow/server=default-server/https-listener=aaa:add(socket-binding=ajp)                                 
      {
          "outcome" => "failed",
          "failure-description" => "WFLYCTL0172: ssl-context is required",
          "rolled-back" => true
      }
      

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  soul2zimate Chao Wang
                  Reporter:
                  soul2zimate Chao Wang
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  1 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: