Uploaded image for project: 'WildFly Core'
  1. WildFly Core
  2. WFCORE-2315

Remoting client from older WildFly can't authenticate against latest WildFly Core

    Details

      Description

      Using dependencies from older WildFly release, clients are unable to connect to latest WildFly using DIGEST-MD5 mechanism:

      java.lang.RuntimeException: javax.security.sasl.SaslException: Authentication failed: all available authentication mechanisms failed:
         DIGEST-MD5: Server rejected authentication
      

      JBOSS-LOCAL-USER method works. I'm talking about latest WildFly with legacy security realms.

      We are supposed to maintain backward compatibility with older clients but in this case older client won't work against newer server.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  dlofthouse Darran Lofthouse
                  Reporter:
                  dlofthouse Darran Lofthouse
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  1 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: