Uploaded image for project: 'Weld'
  1. Weld
  2. WELD-784

Servlet / listener / filter injection support for Jetty 7.2

    Details

      Description

      The fix committed for WELD-729 doesn't work under Jetty 7.2. It appears that the Jetty API has changed between 7.1 and 7.2, which results in servlet/etc injection not working.

      I haven't tested under 8.0 but I notice that the fix refers to 8.0M0, I had to update that dependency to 8.0M2 in order to get my changes for 7.2 to compile, which meant I also had to change the jetty 8 support to fix those compile errors.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                alesj AleŇ° Justin
                Reporter:
                bpsommerville Ben Sommerville
              • Votes:
                1 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: