Details

      Description

      Currently we use assembly plugin in version 2.6 which crashes JDK 9 build because it internally uses old plexus archiver version.
      All this boils down to JEP-223 (better known as project Verona) which changed the Java version string from "1.8" to "9".

      Solution is to:

      • Update assembly plugin to 3.0.0 (preferable)
      • Keep 2.6 and update its dependency on plexus archiver to 3.0.3
        • Only if we for some reason need to keep older version (unlikely)

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                manovotn Matej Novotny
                Reporter:
                manovotn Matej Novotny
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: