Details

      Description

      Proxies for classes with interceptors depend on the following packages:

      org.jboss.weld.interceptor.proxy
      org.jboss.weld.interceptor.util.proxy
      

      These packages have to be exported by weld-osgi-bundle, or else interceptor proxies will not work in OSGi.

      (Note: Surfaced in a test with Pax CDI and DeltaSpike Security where one of the bean classes involved has package visibility.)

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                hwellmann.de Harald Wellmann
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: