Weld
  1. Weld
  2. WELD-1443

Stateless session bean invocation takes 30% longer with Weld 2.0

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved (View Workflow)
    • Priority: Major Major
    • Resolution: Out of Date Out of Date
    • Affects Version/s: 2.0.0.Final
    • Fix Version/s: None
    • Component/s: Weld SPI
    • Labels:
      None
    • Environment:
      This is observed in Glassfish 4
    • Steps to Reproduce:

      1. Deploy an application with a stateless session bean (@Stateless annotation) with CDI 1.1 implicit behavior disabled, and invoke the application to exercise the session bean.

      2. Deploy an application with a stateless session bean (@Stateless annotation), and invoke the application to exercise the session bean.

      3. Measure the difference in performance between the two; It's significant.

      Show
      1. Deploy an application with a stateless session bean (@Stateless annotation) with CDI 1.1 implicit behavior disabled, and invoke the application to exercise the session bean. 2. Deploy an application with a stateless session bean (@Stateless annotation), and invoke the application to exercise the session bean. 3. Measure the difference in performance between the two; It's significant.
    • Similar Issues:
      Show 10 results 

      Description

      Micro benchmarks on EJB local session beans have regressed by 30% because of implicit CDI.

      The problem is that the WeldListener requestInitialized() and requestDestroyed() methods are consuming large amounts of CPU. These are all simple requests to call a business method on a stateless bean.

        Activity

        Phil Zampino
        added a comment -

        I'll add more details if/when the performance folks provide them to me.

        Show
        Phil Zampino
        added a comment - I'll add more details if/when the performance folks provide them to me.
        Jozef Hartinger
        added a comment -

        Phil Zampino, do you have any more details? Especially information about which parts of WeldListener consume the most CPU time would be helpful.

        Show
        Jozef Hartinger
        added a comment - Phil Zampino , do you have any more details? Especially information about which parts of WeldListener consume the most CPU time would be helpful.
        Jozef Hartinger
        added a comment -

        Most likely, the observed problem is addressed by WELD-1496 or WELD-1478. Feel free to reopen if the problem does not go away after upgrading to 2.1.0.CR1 or better.

        Show
        Jozef Hartinger
        added a comment - Most likely, the observed problem is addressed by WELD-1496 or WELD-1478 . Feel free to reopen if the problem does not go away after upgrading to 2.1.0.CR1 or better.

          People

          • Assignee:
            Jozef Hartinger
            Reporter:
            Phil Zampino
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: