Uploaded image for project: 'Weld'
  1. Weld
  2. WELD-1373

org.jboss.weld.se:weld-se-core:1.1.11 contains javax.enterprise:cdi-api:1.0-SP4 and -SP3

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 1.1.11.Final
    • Fix Version/s: 1.1.13.Final
    • Component/s: None
    • Labels:
      None

      Description

      maven-enforcer-plugin 1.2 reports dependency convergence error:

      +-org.jboss.weld.se:weld-se-core:1.1.11.Final
      +-org.jboss.weld:weld-spi:1.1.Final
      +-javax.enterprise:cdi-api:1.0-SP3
      and
      +-org.jboss.weld.se:weld-se-core:1.1.11.Final
      +-javax.enterprise:cdi-api:1.0-SP4
      and
      +-org.jboss.weld:weld-core:1.1.11.Final
      +-javax.enterprise:cdi-api:1.0-SP4
      and
      +-org.jboss.weld:weld-core:1.1.11.Final
      +-org.jboss.weld:weld-api:1.1.Final
      +-javax.enterprise:cdi-api:1.0-SP3

      With that, we can't use maven-enforcer-plugin in the top POM of our project.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                luksa Marko Luksa
                Reporter:
                bojanantonovic Bojan Antonovic
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: