Weld
  1. Weld
  2. WELD-1025

weld-servlet.jar must not contain SLF4J 1.5.X

    Details

    • Steps to Reproduce:
      Hide

      Add weld-servlet to tomcat class path, add SLF4J 1.6.X api and an simple implementation in a servlet call slf4j logger

      Show
      Add weld-servlet to tomcat class path, add SLF4J 1.6.X api and an simple implementation in a servlet call slf4j logger
    • Similar Issues:
      Show 10 results 

      Description

      weld-servlet.jar contains slf4j version > 1.5.10. SLF4J is currently in 1.6.X series and has an incompatibility with 1.5.X. weld-servlet should not contain slf4j 1.5.X This creates some nasty problems with projects depending on SLF4J 1.6. It has been a show stopper for me and using JBoss AS 7 or Glassfish is not an option unfortunately. weld-servlet-int pom is old and has not the 1.1.4.Final version.

        Activity

        There are no comments yet on this issue.

          People

          • Assignee:
            Ales Justin
            Reporter:
            Ukyo Virgden
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: