Uploaded image for project: 'TorqueBox'
  1. TorqueBox
  2. TORQUE-755

mod_cluster should be easier to setup

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 2.0.0
    • Fix Version/s: 2.0.1
    • Component/s: None
    • Labels:
      None

      Description

      It has become a little difficult to hook TorqueBox up with mod_cluster. This could be improved with two enhancements/bug-fixes:

      1) add instance-id="$

      {jboss.node.name}

      " to the web subsystem element
      2) add advertise-security-key="secret" to the modcluster subsystem element.

      I think #1 should be added by default. And I would like to see #2 added by default, but I could see why it would not be for security reasons.

      For #2 it might make more sense to have a setup script that modified standalone-ha.xml (the way that the java_to_ruby.rb script did for openshift). But this script could even accept a config file, or maybe prompt the user for some values. I'll probably write that either way.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                benbrowning Benjamin Browning
                Reporter:
                codefinger Joe Kutner
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: