TorqueBox
  1. TorqueBox
  2. TORQUE-738

Torquebox/JBoss tries to deploy netty jar as application

    Details

    • Type: Bug Bug
    • Status: Closed Closed (View Workflow)
    • Priority: Major Major
    • Resolution: Cannot Reproduce Bug
    • Affects Version/s: 2.0.0.CR1
    • Fix Version/s: 2.0.0
    • Component/s: Services
    • Environment:
    • Workaround:
      Workaround Exists
    • Workaround Description:

      Temporary solution: move outside the application directory

      Show
      Temporary solution: move outside the application directory
    • Similar Issues:
      Show 10 results 

      Description

      Jboss/Torquebox tries to deploy Netty(http://netty.io) as application and fails. By failing deploying the Netty jar, also the main application is not deployed.

      Jar was found in these locations: lib/libs; lib/jars; app/services;

        Activity

        Benjamin Browning
        added a comment -

        I tried to reproduce this on latest 2x-dev branch but am not having success. I placed netty-3.3.0.Final.jar (the version I thought I remembered you using from IRC) in a lib/jars/ directory under my application root and everything deployed fine - AS7 didn't pick up or do anything special with the netty jar and I was able to require it from my Rack application without any problems.

        Were you using a different version of the netty jar? Did this only happen under specific circumstances?

        Show
        Benjamin Browning
        added a comment - I tried to reproduce this on latest 2x-dev branch but am not having success. I placed netty-3.3.0.Final.jar (the version I thought I remembered you using from IRC) in a lib/jars/ directory under my application root and everything deployed fine - AS7 didn't pick up or do anything special with the netty jar and I was able to require it from my Rack application without any problems. Were you using a different version of the netty jar? Did this only happen under specific circumstances?
        Marek Jelen
        added a comment -

        Hmmm ... today I had to refactor the application and it had not happened with simple Rack application.

        That's why I asked on IRC whether it's possible to the issue be related to Rails.

        Show
        Marek Jelen
        added a comment - Hmmm ... today I had to refactor the application and it had not happened with simple Rack application. That's why I asked on IRC whether it's possible to the issue be related to Rails.
        Benjamin Browning
        added a comment -

        I was unable to reproduce this by placing the netty jar inside lib/jars of a Rails app either. I don't see anything in our code that would make this issue be related to Rails. If you're still able to reproduce this I'll need some help tracking down what's going on.

        Show
        Benjamin Browning
        added a comment - I was unable to reproduce this by placing the netty jar inside lib/jars of a Rails app either. I don't see anything in our code that would make this issue be related to Rails. If you're still able to reproduce this I'll need some help tracking down what's going on.
        Marek Jelen
        added a comment -

        The only thing I have to do is to copy netty.jar into the application directory.

        stop torquebox
        cp netty.jar /home/torquebox/web/
        start torquebox

        and I get

        09:13:28,216 INFO [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015876: Starting deployment of "netty.jar"
        09:13:28,219 INFO [org.jboss.as.server.deployment] (MSC service thread 1-2) JBAS015876: Starting deployment of "web"
        09:13:30,039 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-1) MSC00001: Failed to start service jboss.deployment.unit."netty.jar".POST_MODULE: org.jboss.msc.service.StartException in service jboss.deployment.unit."netty.jar".POST_MODULE: Failed to process phase POST_MODULE of deployment "netty.jar"
        at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:119) [jboss-as-server-7.1.0.Final.jar:7.1.0.Final]
        at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]
        at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110) [rt.jar:1.6.0_23]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603) [rt.jar:1.6.0_23]
        at java.lang.Thread.run(Thread.java:679) [rt.jar:1.6.0_23]
        Caused by: java.lang.NullPointerException
        at org.jboss.as.ejb3.deployment.processors.IIOPJndiBindingProcessor.bindService(IIOPJndiBindingProcessor.java:108)
        at org.jboss.as.ejb3.deployment.processors.IIOPJndiBindingProcessor.deploy(IIOPJndiBindingProcessor.java:77)
        at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:113) [jboss-as-server-7.1.0.Final.jar:7.1.0.Final]
        ... 5 more

        then by removing the JAR

        stop torquebox
        rm /home/torquebox/web/netty.jar
        start torquebox

        there is no problem.

        ------------

        It's a regular Rails application. Some non-standard configuration options.

        config.autoload_paths += %W(#

        {config.root}/lib)
        config.autoload_paths += %W(#{config.root}

        /app/services)
        config.assets.enabled = false
        config.threadsafe!

        Gems:

        gem 'rails', '3.2.2'

        gem 'activerecord-jdbc-adapter'
        gem 'jdbc-mysql'

        gem 'jruby-openssl'
        gem 'json'

        gem 'devise'

        gem 'activemerchant'

        gem 'torquebox-messaging', '~> 2.0.0.cr1'
        gem 'torquebox-transactions', '~> 2.0.0.cr1'

        gem 'httparty'

        Show
        Marek Jelen
        added a comment - The only thing I have to do is to copy netty.jar into the application directory. stop torquebox cp netty.jar /home/torquebox/web/ start torquebox and I get 09:13:28,216 INFO [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015876: Starting deployment of "netty.jar" 09:13:28,219 INFO [org.jboss.as.server.deployment] (MSC service thread 1-2) JBAS015876: Starting deployment of "web" 09:13:30,039 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-1) MSC00001: Failed to start service jboss.deployment.unit."netty.jar".POST_MODULE: org.jboss.msc.service.StartException in service jboss.deployment.unit."netty.jar".POST_MODULE: Failed to process phase POST_MODULE of deployment "netty.jar" at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:119) [jboss-as-server-7.1.0.Final.jar:7.1.0.Final] at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.2.GA.jar:1.0.2.GA] at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.2.GA.jar:1.0.2.GA] at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110) [rt.jar:1.6.0_23] at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603) [rt.jar:1.6.0_23] at java.lang.Thread.run(Thread.java:679) [rt.jar:1.6.0_23] Caused by: java.lang.NullPointerException at org.jboss.as.ejb3.deployment.processors.IIOPJndiBindingProcessor.bindService(IIOPJndiBindingProcessor.java:108) at org.jboss.as.ejb3.deployment.processors.IIOPJndiBindingProcessor.deploy(IIOPJndiBindingProcessor.java:77) at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:113) [jboss-as-server-7.1.0.Final.jar:7.1.0.Final] ... 5 more then by removing the JAR stop torquebox rm /home/torquebox/web/netty.jar start torquebox there is no problem. ------------ It's a regular Rails application. Some non-standard configuration options. config.autoload_paths += %W(# {config.root}/lib) config.autoload_paths += %W(#{config.root} /app/services) config.assets.enabled = false config.threadsafe! Gems: gem 'rails', '3.2.2' gem 'activerecord-jdbc-adapter' gem 'jdbc-mysql' gem 'jruby-openssl' gem 'json' gem 'devise' gem 'activemerchant' gem 'torquebox-messaging', '~> 2.0.0.cr1' gem 'torquebox-transactions', '~> 2.0.0.cr1' gem 'httparty'
        Benjamin Browning
        added a comment -

        What version of netty are you using? Could you attach the .jar you're using?

        Show
        Benjamin Browning
        added a comment - What version of netty are you using? Could you attach the .jar you're using?
        Marek Jelen
        added a comment -

        Netty jar that is causing problems.

        Show
        Marek Jelen
        added a comment - Netty jar that is causing problems.
        Show
        Bob McWhirter
        added a comment - Added integration app and test, unable to reproduce as described. https://github.com/torquebox/torquebox/tree/2x-dev/integration-tests/apps/rails3/break-jar https://github.com/torquebox/torquebox/blob/2x-dev/integration-tests/spec/rails_break_jar_spec.rb
        Bob McWhirter
        added a comment -

        CI agrees that this doesn't fail.

        Show
        Bob McWhirter
        added a comment - CI agrees that this doesn't fail.

          People

          • Assignee:
            Bob McWhirter
            Reporter:
            Marek Jelen
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: