Uploaded image for project: 'TorqueBox'
  1. TorqueBox
  2. TORQUE-477

Starting Rails 3.1 app fails due to "Application has been already initialized"

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 1.0.1, 2.0.0.Beta1
    • Fix Version/s: 1.1, 2.0.0.Beta1
    • Component/s: None
    • Labels:
      None
    • Steps to Reproduce:
      Hide

      gem install torquebox-server --pre --source http://torquebox.org/2x/builds/LATEST/gem-repo/
      gem install rails --pre
      rails new test_app
      torquebox deploy test_app
      torquebox run

      Then navigate to the applications web address.

      Show
      gem install torquebox-server --pre --source http://torquebox.org/2x/builds/LATEST/gem-repo/ gem install rails --pre rails new test_app torquebox deploy test_app torquebox run Then navigate to the applications web address.

      Description

      When attempting to deploy and run a bare Rails 3.1 app using 2.x.incremental.222 and 223 the app fails with: "Application has been already initialized." A full stack is available at https://gist.github.com/1070501.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                tcrawley Toby Crawley
                Reporter:
                digitaltoad Joshua Borton
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: