Uploaded image for project: 'Teiid Designer'
  1. Teiid Designer
  2. TEIIDDES-1936

Designer fails to connect to the latest version of the Teiid Runtime.

    XMLWordPrintable

    Details

      Description

      When Designer 8.3 Beta is used to connect to the latest version of the Teiid 8.6 Beta, it fails to connect for preview or execution of VDB purposes. The server connection dialog always says

      11:30:39,396 ERROR [org.jboss.remoting.remote.connection] (Remoting "user:MANAGEMENT" read-1)  JBREM000200: Remote connection failed: java.io.IOException: Connection reset by peer
       
      java.lang.Exception: No ExecutionAdmin factory registered for teiid instance version 8.5.0.Final.
        at org.teiid.designer.runtime.registry.TeiidRuntimeRegistry.getExecutionAdminFactory(TeiidRuntimeRegistry.java:87)
        at org.teiid.designer.runtime.registry.TeiidRuntimeRegistry.getExecutionAdmin(TeiidRuntimeRegistry.java:101)
        at org.teiid.designer.runtime.TeiidServer.connect(TeiidServer.java:217)
        at org.teiid.designer.runtime.TeiidServer.reconnect(TeiidServer.java:237)
        at org.teiid.designer.runtime.TeiidParentServerListener.serverChanged(TeiidParentServerListener.java:146)
        at org.eclipse.wst.server.core.internal.ServerNotificationManager.broadcastChange(ServerNotificationManager.java:125)
        at org.eclipse.wst.server.core.internal.Server.fireServerStateChangeEvent(Server.java:742)
        at org.eclipse.wst.server.core.internal.Server.setServerState(Server.java:650)
        at org.eclipse.wst.server.core.model.ServerBehaviourDelegate.setServerState(ServerBehaviourDelegate.java:143)
        at org.jboss.ide.eclipse.as.core.server.internal.DeployableServerBehavior.setServerStarted(DeployableServerBehavior.java:210)
        at org.jboss.ide.eclipse.as.core.server.internal.DelegatingServerBehavior.setServerStarted(DelegatingServerBehavior.java:100)
        at org.jboss.ide.eclipse.as.core.server.internal.AbstractJBossBehaviourDelegate$1.stateAsserted(AbstractJBossBehaviourDelegate.java:96)
        at org.jboss.ide.eclipse.as.core.server.internal.PollThread.alertListener(PollThread.java:230)
        at org.jboss.ide.eclipse.as.core.server.internal.PollThread.handlePollerHasAnswer(PollThread.java:159)
        at org.jboss.ide.eclipse.as.core.server.internal.PollThread.run(PollThread.java:147)
      
      

      Designer from its latest version must always allow to connect to the latest version of the Teiid, as Teiid in a given major revision most of the times allows backwards compatibility.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                rareddy Ramesh Reddy
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: