SwitchYard
  1. SwitchYard
  2. SWITCHYARD-614

JMS Headers not available on Camel Route

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved (View Workflow)
    • Priority: Major Major
    • Resolution: Done
    • Affects Version/s: 0.3
    • Fix Version/s: 0.4
    • Component/s: component-camel
    • Labels:
      None
    • Environment:
      MacOSX 10.7.2, java version "1.6.0_29" jboss-as-7.1.0.CR1b
    • Steps to Reproduce:
      • git clone https://github.com/cvasilak/nms-java-parent
      • cd nms-java-parent
      • mvn install
      • cd ..
      • git clone https://github.com/cvasilak/svc-rrd-parent
      • cd svc-rrd-parent
      • mvn clean install -Dmaven.test.skip=true
      • cp svc-rrd-model/target/svc-rrd-model-1.0-SNAPSHOT.jar /jboss-as-7.1.0.CR1b/standalone/deployments/
      • cp svc-rrd-service/target/svc-rrd-service-1.0-SNAPSHOT.jar /jboss-as-7.1.0.CR1b/standalone/deployments/
      • cd svc-rrd-service/
      • mvn test

      The test will create A JMS message, set a header property to "type":"register" and send it to server together with JSON payload body.

      Watch on the console that only the property breadcrumbId is printed out.

      10:25:35,639 INFO [stdout] (Camel (camel-4) thread #0 - JmsConsumer[svc_rrd_ctrl_bus) breadcrumbId: ID-casper-rd-forthnet-gr-50333-1326443118227-1-2

      Show
      git clone https://github.com/cvasilak/nms-java-parent cd nms-java-parent mvn install cd .. git clone https://github.com/cvasilak/svc-rrd-parent cd svc-rrd-parent mvn clean install -Dmaven.test.skip=true cp svc-rrd-model/target/svc-rrd-model-1.0-SNAPSHOT.jar /jboss-as-7.1.0.CR1b/standalone/deployments/ cp svc-rrd-service/target/svc-rrd-service-1.0-SNAPSHOT.jar /jboss-as-7.1.0.CR1b/standalone/deployments/ cd svc-rrd-service/ mvn test The test will create A JMS message, set a header property to "type":"register" and send it to server together with JSON payload body. Watch on the console that only the property breadcrumbId is printed out. 10:25:35,639 INFO [stdout] (Camel (camel-4) thread #0 - JmsConsumer[svc_rrd_ctrl_bus) breadcrumbId: ID-casper-rd-forthnet-gr-50333-1326443118227-1-2
    • Similar Issues:
      Show 10 results 

      Description

      When trying to access the JMS headers from a Camel Route, the list returned contains only one property[breadcrumbId]. All other properties are discarded.

        Activity

        David Ward
        added a comment -

        Christos,

        You have this in your pom:

        <parent>
        <groupId>gr.forthnet.nms</groupId>
        <artifactId>nms-java-parent</artifactId>
        <version>1.0.0-SNAPSHOT</version>
        </parent>

        <groupId>gr.forthnet.nms.svcrrd</groupId>
        <artifactId>svc-rrd-parent</artifactId>
        <version>1.0-SNAPSHOT</version>
        <packaging>pom</packaging>

        , and maven can't resolve nms-java-parent. Where is it?

        Thanks,
        David

        Show
        David Ward
        added a comment - Christos, You have this in your pom: <parent> <groupId>gr.forthnet.nms</groupId> <artifactId>nms-java-parent</artifactId> <version>1.0.0-SNAPSHOT</version> </parent> <groupId>gr.forthnet.nms.svcrrd</groupId> <artifactId>svc-rrd-parent</artifactId> <version>1.0-SNAPSHOT</version> <packaging>pom</packaging> , and maven can't resolve nms-java-parent. Where is it? Thanks, David
        Christos Vasilakis
        added a comment -

        Hi David, sorry I missed that...

        Please do a "mvn install" on the git repository here "https://github.com/cvasilak/nms-java-parent" to install it

        And please do a git pull to synchronize because I have made some changes. Basically I removed the dependency for camel-jackson to be installed on the server. Just a pure send-receive JMS message.

        Note you must run the jboss-as-7 with the standalone-full profile to enable the JMS subsystem

        Let me know if you need more information

        Regards,
        Christos

        Show
        Christos Vasilakis
        added a comment - Hi David, sorry I missed that... Please do a "mvn install" on the git repository here "https://github.com/cvasilak/nms-java-parent" to install it And please do a git pull to synchronize because I have made some changes. Basically I removed the dependency for camel-jackson to be installed on the server. Just a pure send-receive JMS message. Note you must run the jboss-as-7 with the standalone-full profile to enable the JMS subsystem Let me know if you need more information Regards, Christos
        David Ward
        added a comment -

        Christos, Please see my comment about adding a <contextMapper/> element to your <binding.camel/> here: http://goo.gl/q7XEP . Thanks, David.

        Show
        David Ward
        added a comment - Christos, Please see my comment about adding a <contextMapper/> element to your <binding.camel/> here: http://goo.gl/q7XEP . Thanks, David.
        Show
        David Ward
        added a comment - https://github.com/jboss-switchyard/components/pull/278
        Keith Babo
        added a comment -

        pushed

        Show
        Keith Babo
        added a comment - pushed

          People

          • Assignee:
            David Ward
            Reporter:
            Christos Vasilakis
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: